SPForm not doing anything

I get a blank screen, no errors, no mails when sending from this form. Yes, set to debug etc. I even erased and installed a fresh copy.
Very mysterious, I am used to working with this extra.
Site is buddhistisksamfund.dk on a shared server, php is 8.2
It is not the ‘kontact os’ link - this goes to a sub-site running on BackdropCMS
Tried disabling modsecurity - no change.
What else should I look at?

When you open the developer tools in the browser (tab “Network”) what HTTP response status code do you get? 500?

Did you only check the MODX error log or also the server/PHP error log?

No such error in developer (firefox)
The server have no errors.
Very unusual.

The form is here:

It does work but it is trying to send mail to webmaster@…dk I tryed the form and get mail back that this address is not found.

You are right! There was a misspelling, now corrected, in the ‘contact’ resource (the spelling was/is correct in the snippet property sets).
However -for me this did not change anything: I still get the blank ‘response’ - which is an empty version of the ‘contact’ form, and I never get any mail either - and no errors anywhere.
Do you get the ‘response’ thank-you page?

Inspiret by dimmy I tried the contact form in a different browser, chromium, and it worked as it should. I get mail and the ‘thank you’ page.
Why the form works in (linux) firefox for other websites I am hosting on same server, but not this one - I have no clue. Anyone: Any idea?

Only thing missing now is the ‘tale-me-back’ button. Should be there according to debug ‘response but isn’t’:


spfresponseTpl: spfresponseTpl
takeMeBack: 1


Which version of SPForm are you referring to? A new version was released in the last few days. Is that the one we’re discussing?

I just updated, but it was previous version - with the period-comma fix though.
After update I get a 404 since the form tries to go to https://buddhistisksamfund.dk/contact/contact/ instead of ‘thank-you’. Yes the response ID is set correctly. And no mail is send.
It is only on this site, that I have these problems. Maybe an interference from another extra?

That’s odd. It could be an conflict with another extra, a Firefox extension you have installed, or a JavaScript conflict.

Do you see any thing in Dev. Tools (Ctrl-shift-i) when you load or send?

I set the debug on. Here is the form now:

SPFormPath: /home/buddhistisk/public_html/core/components/spform/
iFile = /home/buddhistisk/public_html/core/components/spform/spfdebug.php
spformTpl: spformTpl
spformprocTpl: spformprocTpl
spfcaptchaTpl: spfcaptchaTpl
formProcAllowedReferers: buddhistisksamfund.dk
recipientArray: Webmaster: webmaster@buddhistisksamfund.dk
spfResponseID: 27
errorsto: choan@rinzai.dk
adviseAll: 1
warnAll: 1
spfSMTP_Host: yourhost.com
spfSMTP_Port: 587
useHiddenField: 1
useTimer: 1
useTimerMin: 10
useTimerMax: 1800
addSubjSig: 1
dfltSubj: Contact
maxRecipientLen: 65
maxSubjectLen: 100
maxLinks: 3
requireName: 1
requireSubj: 1
requireEmail: 1
spTextRows: 10
spTextCols: 50
usemathString: 1
warnVerify: 1
reportRemoteHost: 1
reportRemoteUser: 1
reportRemoteAddr: 1
reportRemoteIdent: 1
reportOrigReferer: 1
formProcBlankRefOkay: 1
chkFormRefNotSelf: 1
Skriv ikke
dit efternavn her:
time = 1714889282
time = 1714903825

Dit navn:
Email adresse:
Skriv venligst din besked nedenfor. Klik “Send” når du er klar:

Anything ‘sticking out’?
And the 404 I get in chromium as well.

It gets worse. Now I have same behavior at other sites (sensistop.dk) - blank ‘contact’ page in firefox, no takemeback button in chromium.

Just made a completely fresh clean install of ModX and added SPForm - same exact problems. Blank form in Firefox and no mail send, mail send and ‘thankou’ without takemeback button in chromium. I am using LinuxMint on my computer.

That’s weird. It’s working for me with Firefox and Chrome, don’t have Chromium to test it with.

Does it work if you undo the fix (change the comma back to a period)?

I am using the newest version.
Just tried ‘cleaning up’ in firefox - closing most pages, clearing all cached data: No difference.
It might be a ‘local’ problem here, but I will not use SPForm if I can not test it here (and the takemeback button doesn’t show).

Here is an english version of the site: Contact - Buddhist Society -working to a degree in chromium.
Danish version is not working: https://buddhistisksamfund.dk/contact/ -tries to go to contact/contact

The reason you’re not seeing the take-me-back link is that your original referer is not set. This depends on the session variable, $_SERVER["HTTP_REFERER"].

Sometimes, this is not ever set in localhost installs (e.g., XAMPP).

Also, if you go directly to the contact page, there is no referring page, so it won’t (and can’t) be set. Does it appear of you are on another page and click on a link to the contact page.

One more thing, make sure your spfResponseTpl contains these placeholders:



Thank you Bob for clearing that up. When contact form is reached from somewhere else (front) via menu the takemeback button is indeed there and functioning as designed - for the english site. The danish site still tries to find ‘contact/contact’

Edit: After copying the spform snippet from english to danish site, fhe form works as expected in chromium.

There is something off with my firefox - sorry for all the trouble.

By the way Bob. I never got to send you the danish lexicon file. Front is translated, but not backend (yet). How can I get it to you?

In Firefox in troubleshooting mode all is fine. SPForm work as advertised.
Now I have to dig down to see where the problem stems from.

Update: When I use LastPass to fill out the form I get the blank contact page. Filling in manually all is fine.
I am sure many use Lastpass or similar to fill out forms, so I would call it a bug.