NewsPublisher not loading with rte

Im trying to set up front end publishing for my client because he is on mobile mostly and Modx’s Manager is not very mobile friendly. So I thought front end ediging and publishing is good choice.

I am setting up with NewsPublisher Extra and getting blank page when im trying with example snippet. But if I choose to disable initrte by setting 0 then my page loads.

I dont know what error is causing this. Its fresh install, Fresh Extra Installed and example snippet using.

[[!NewsPublisher?
        &show=`pagetitle,description,pub_date,introtext`
        &initrte=`1`
        &initdatepicker=`1`
        &initfilebrowser=`1`
        &rtcontent=`1`
        &rtsummary=`1`
        &parentid=`12`
        &published=`1`
        &captions=`content:Enter Post,introtext:Summary,description:Give a brief description`
    ]]

Not find anything special to set up for rte, everything is ready to rock… so im confuse what im missing.
Please help.
@bobray sir …

I don’t see anything wrong with what you’re doing. Is there anything in the MODX error log?

Is this happening just on mobile, or do you get the same thing in the desktop?

If you turn on Dev. tools in Chrome or Firefox (F12 or Ctrl-shift-i), do you see any JS errors on the console tab after launching NP?

If you watch the Network tab when loading NP, do you see any 404 errors that might be related to the problem?

I’m not sure how well TinyMCE is going to work on a mobile device. I’ve never tried it.

I get nothing in error log and in console but when i switch to http from https, I get login page, whose id is set in newspublisher system settings.
But when I login from there, I get blank page again. And in network -> html tab in dev console, I get status 500, Method GET, File - https://domain.com/index.php?id=13
id 13 is the newspublisher page id and here is my login page data whose id is 16-

<p>[[!Login? loginResourceId=13]]</p>

And here is my NewsPublisher page data -

[[!NewsPublisher? 
&show=`pagetitle,YoutubeVideoHdaLive,content` 
&templateid=`4` 
&initdatepicker=`1` 
&initfilebrowser=`1` 
&initrte=`1` 
&rtcontent=`1` 
&parentid=`2` 
&published=`1` 
&aliastitle=`1` 
&captions=`content:Enter Post` ]]

The 500 response indicates a server error. Unfortunately, I can’t think of any reason why just including the TinyMCE code would cause that.

The only thing I can think of to suggest is to go to this URL (https://download.tiny.cloud/tinymce/community/tinymce_4.9.11.zip). Download and unzip TinyMCE and put the extracted JS file in the assets/components/newspublisher directory.

Then add this to your NewsPublisher tag:

&tinysource=`https://yoursite.com/assets/components/newspublisher/tinymce_whatever_.js`

Replace yoursite.com with your site’s base URL and correct the tinymce file name to match whatever you extract from the downloaded .zip file.

It probably won’t help, but it’s the only thing I can think of.

I will try that in few minutes.
Till then I want to let you know that when I disable the initrte field, the page goes up and i can post from front end but when I turn on rte then i get blank page.
Strange.

@mayanktaker Did you have any luck with this?
I’m running into the same sort of problem… I’ve isolated it to the &initrte parameter. All works if off (except the RTF) blank screen if on. Have tried with TinyMCS Rich Text Editor 2.0.1 and TinyMCE 4.3.4. (Modx Rev 2.8.3)
A Chrome bug comes up “crbug/1173575, non-JS module files deprecated.” in Chrome/Brave
No bugs in the console in Safari.