MODX 3.0.1 only MIGX template variables appearing in resources

Only Migx template variables are showing up in my resources despite TVs of other types being allocated to that template.

I’ve just installed MODX 3.0.1-pl onto a new Prostack-hosted site via Softaculous on cPanel.

I’ve created some templates, resources and template variables of various types (text, image, Migx). All fairly standard stuff.

I’ve allocated the template variables to the templates that they relate to, and allocated those templates to the relevant resources. When I click into any resource and click on the Template Variables tab, it’s only the Migx TVs that appear – no sign of any of the other TVs, even though they are definitely allocated to that template.

Have anyone else experienced this or got any tips for a fix?

I’ve tried clearing the cache, logging out and in again. I checked the error log and it’s rammed with errors like these:

[2022-05-17 16:03:25] (ERROR @ /home2/bullochp/public_html/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 666) Could not load class: modFileHandler from modfilehandler
[2022-05-17 16:03:25] (ERROR @ /home2/bullochp/public_html/core/vendor/xpdo/xpdo/src/xPDO/xPDO.php : 1267) Problem getting service fileHandler, instance of class modFileHandler, from path

It doesn’t look possible to install an older version of MODX via Softaculous so I’m stuck with version 3.0.1.

Screenshots attached showing a template and the TVs associated with it; a page with that template allocated to it; and that page with only the migx TV showing up.

Does this help at all?

I’m afraid not :frowning:

I’ve just tried a completely fresh install of 3.0.1 from Softaculous and created a TV associated with the BaseTemplate that’s applied to the Home page, and it doesn’t show up. So it’s nothing to do with any of the Extras that I’d installed when I tried this earlier. Seems like something fundamentally wrong with a fresh install of version 3.0.1??

Incidentally, I tried a fix that I read on another thread that suggested using system settings to set the CMS version to v2 and then use the UpgradeModx Extra to upgrade to v3 but it complete broke my previous site.

I’m a bit stuck as to how to move forward with this. Any other suggestions?

I think you’re right @claireallan … I’ve just created a fresh install of 3.0.1 via softaculous.

Created a Text TV with access to the BaseTemplate.

Does not show on the Home page, which uses that template.

Have tried creating a further Template and assigning the new TV to that - still any page using that template does not see any TV tab.

Update … I’ve tried:

  • different types of TV
  • adding the TVs to a category
  • giving the TVs a Sort Order
  • moving the TVs to a different tab using Form Customisation

Still no sign of them.

I can also confirm that another installation I have which was 3.0 installed by Softaculous, subsequently updated to 3.0.1, seems to work OK. So it would seem to only be an issue with fresh installs of 3.0.1 [certainly via Softaculous]

Nothing at all in the error log

Hi @dejaya – thanks for doing all that testing. I’m actually glad it’s not just me who’s now experienced this issue!

I’ll pick it up again in the morning and try an install of 3.0.0 manually (I can’t see any way of installing an older version via Softaculous).

If anyone has any fixes for this that they can suggest that would be much appreciated, as it’ll be a common issue I think if fresh installs of the newer versions don’t work properly.


I’ve just completed a fresh install of 3.0.1 manually via /setup

The environment is otherwise identical - however all works as expected.

If you can install that way it looks like you’ll be ok.

As for what’s up with the Softaculous installer - I wouldn’t know where to start!

Oh brilliant @dejaya - I’ll see how I get on with a manual install of version 3.0.1 tomorrow.

I’ll steer clear of Softaculous for now!

Thanks for your helpful investigating.

It’s not the first time that a Softaculous install has gone haywire (and probably not the last).

BTW, you can use UpgradeMODX to “upgrade” to the current version by setting the settings_version System Setting back (the version you set it to doesn’t even have to exist, as long as it would be an earlier version).

I suspect that doing that might have fixed your Softaculous install.

Another tip is to clear the site cache, either manually, or with the CacheClear extra, and clear your browser cache and cookies after an upgrade of MODX. I think CacheClear is more aggressive than the Manager’s Clear Cache action. It’s also a lot easier than doing it manually.

You could maybe try the installer Bruno17/installer (

Thanks @bobray and @bruno17

I’ve tried your UpgradeMODX fix Bob and that seems to have done the trick – I tried it previously and I got errors and couldn’t even log into the site, but maybe because I just put 3.0.0 and not 3.0.0-pl??). Anyway, it’s worked this time and I’m back up and running.

Bruno – Thanks for that link. I’ll try that if I need to do a manual install in future.

For anyone else reading this looking for the workaround:

Either don’t use Softaculous and do a manual install instead;
Or install 3.0.1-pl from Softaculous, in system settings change settings_version to 3.0.0-pl, and then use the UpgradeMODX extra to upgrade to 3.0.1-pl. Use CacheClear extra to thoroughly clear the cache after the upgrade.

Thanks for your help all!

Looking at the core/config/ files for each installation, there’s one thing that looks wrong on the Softaculous installation:

Using /setup

Line 30:

$modx_processors_path= '/home/xxxxx/modx-setup/core/src/Revolution/Processors/';

Using Softaculous

Line 30:

$modx_processors_path= '/home/xxxxx/modx-softaculous/core/model/modx/processors/';

This folder does not exist. Does the Softaculous installer perhaps have an outdated file from 2.x?


Just to confirm - switching the above line to /core/src/Revolution/Processors/ fixes the Template Variables issue.

1 Like

Hi @dejaya – that’s great that you’ve found a quick solution by just changing that one line of code. Hopefully the next release of Modx 3 in Softaculous will have this sorted.

Hey @claireallan

Good work spotting this issue.

Softaculous have now updated their MODX 3.0.1 distribution to fix the config file.

It’s already rolled out to the CPANEL hosts I use - and all seems well.


Hi @dejaya – that’s fantastic that Softaculous have altered that config file already, and well done to you again for figuring out what had to be fixed.

Glad that I know I can use Softaculous for future 3.0.1 installs without having to do any fiddling with code myself!

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.