Login-Extra not working on "Safari-Engine" on Modx 3

In a new project with a fresh Modx 3 installation, the extra login does not work under Mac/Ipad/Iphone and co.
I don’t have any log entries or error messages, I just get the blank login form.
On Win/Linux browsers it works as usual.

I have other projects on the same server with Modx2 and the same version of login extra.
There this extra works under “Apple” as it should.

Do you have any ideas?
I reported this as issues in Git but haven’t gotten any reply or dialog yet. That’s why I’m writing here again in the forum.

What browser did you use on your Mac? Maybe it’s a cookie setting that prevents you from logging in?

Everything is standard, Safari, Chrome and Firefox for IOS. I didn’t notice it at first either, because the page on the Ipad worked like that. I was only registered with my cell phone (android) and Win-PC in the internal area. But then complaints came from users with iphone and ipad. I then tested it with my devices and was able to reproduce it on other MODX installations.

Just to be sure, I ran a quick test again. I tested it on IpadOS 16.2, with Safari. All settings reset. Brought no change, Modx is also on the latest version 3.03.

I don’t have Apple devices to test on - but when I test one of my MODX 3.0.3-pl sites with a Login form on Browserstack [iphone 14 pro and iphone 14 - safari and chrome] - I can see the form OK.

Are you able to share a link to the page in question? Or share your markup for the form?

Ok, let me see what I can do. Unfortunately, emulating IOS/Safari is not enough. You need the engine to reproduce the behavior.

In order to be able to test, I quickly duplicated the project and took out the content.


with the user:

you can now test it yourself with your devices.


I also created a blank page with only the login snippet. Without template or other scripts.

as you will see it works fine under win&android but not under the bitten apple.
And as already described above, no entries or anything like that in the logs.

Can you log in to the manager from an Apple device on your system?

The Login extra runs on the server. I doubt anything with this extra creates the problem. Maybe your browser doesn’t accept the cookie from your site.

Yes, i can. No problemos to login in the manager with my Ipad.

Same server, Modx v2x login works great but Modx v3 doesn’t. Also updateing this v2x to v3… login just working with win and android…

This is still very weird. The same MODX processor that is used to log in to the manager is also used by the Login snippet.

Also, if there was a general problem with MODX 3 and the Login extra, why are you the only one experiencing it? Your Github issue is almost 4 months old, MODX 3 has been released for some time now and the Login extra is widely used on MODX sites.

Yep, that was the reason I posted on the forum. It also surprises me that it only affects several Modx installations for me.

Or very few users use the combination IOS and a modx page with login…

I had already considered whether this problem would occur with another plugin in combination.

If anyone has a brilliant idea, or if we should take a look at the manager, I can make that possible.

I’m open to suggestions.

I use exclusively macOS and iOS and have not run into Login extras issues on any sites, yet. I’d suggest building the smallest possible site that reproduces the issue so that you can upload it to the bug and others can take a look at it.

Links and test users can be found above… feel free to try it with your devices. Is a basic installation (with widely used plugins, as: Articles, Formit, getResources, Login, MIGX, pdoTools, TinyMCE, … nothing special) one with a basic Foundation Zurb Template and the other is a blank page with no content only with the login snippet.

The thing is that site is a fully fledged site, my recommendation is that you start from a blank site and keep adding code until you reproduce the same issue. That way you can distribute it widely to everyone. It’s a standard practice of debugging.

1 Like

I can reproduce the issue on the site provided. With Safari I’m unable to log in, but in Chrome it works fine.

Same for me here: Chrome and Firefox work, Safari is a no.

It might be useful to see what the difference is between the markup of the page from each browser.

You could maybe grab a View Source of each and check for differences here.

Also - there are a lot of javascript sources loaded on the page - it might be worth testing without these loading - just to rule them out.

hey u can try the blank site, there are no javascript sources loaded…

Apologies @mr.tobe - I missed that.

So, if you visit the link at https://modx3.carra.de/index.php?id=13 on one of the problem devices - and the form doesn’t show - is there anything visible in View Source?