Issues with REST API

Just logged into the dashboard and see these errors. I don’t know the reason behind it.
Even I can go to the “Extras” page as well.

Can anyone help me to fix this?

Set the system setting auto_check_pkg_updates to No. Then go to the “Extras” page.

Is there a general problem with connecting to the package provider or is it a single package that creates the problem? Maybe try the “Check For Updates” button for each extra, to see which one causes the issue. Are there extras from other package providers than

Also maybe this PR fixes the issue:

Maybe upgrade to the newest MODX version.

The error has gone.
Thanks a ton.

I’m having a similar issue, all of the sudden searching for extra’s doesn’t seem to work anymore.

@rthrash did something change in the package provider?

Everything changed. The entire extras infrastructure is now driven by a completely new implementation. If someone could work with me to determine what is causing the dashboard issue, I would be grateful as I am not able to reproduce this problem locally. I’m almost certain it has something to do with a specific package (or a few specific packages), but without details, it is going to be difficult to track down.

I can’t reproduce it locally either, my colleague does have a problem. Today we’re kinda busy but I’ll share more info with you on Slack in the upcoming days! E.g installed packages etc.

I ran into the exact issue the other day. I switched back to PHP7.4 to get the welcome screen back and to be able to use the package manager. I upgraded to MODX 3.0.3. I applied the package manager fix above and also had to fix the path to TinyMCE Rich Text Editor - this was mentioned in another thread. Having done this and then updated TinyMCE Rich Text Editor and pdoTools, I was able to switch back to PHP8.1 with no errors.

@opengeek This is not directly related to this topic, but currently when you search for the extra Gallery, it shows a version “0.0.0”, a release date of “1970-01-01” and can’t be downloaded.

I assume this is due to the changes in the package provider as well.

There is no gallery extra available for 3.x according to the repository. There is an unidentified problem in the current releases of package management that is not handling this situation properly, however. It is handled properly in the current 3.x branch, though. I’ll have to get an older release installed and see if there is a way I can modify the provider to prevent that from happening.

Made an upgrade from an old 2.8.3 to 3.0.3 successful. All paths and permissions are correct.
Now I tried to change from the old TinyMCE 4.3.4 to the current TinyMCE 2.0.9. Installation fails with this error message:

Could not find package manifest at /is/htdocs/wp12304759_KJATPTVASM/cms2023/core/packages/tinymcerichtexteditor-2.0.9-pl/manifest.php
Could not unpack package /is/htdocs/wp12304759_KJATPTVASM/cms2023/core/packages/ to /is/htdocs/wp12304759_KJATPTVASM/cms2023/core/packages/. SIG: tinymcerichtexteditor-2.0.9-pl

The manifest.php is there, also the package is unpacked.

(Previously deinstalled phpthumbof and installed pthumb: successful installation, means: other extras installed without problems.)

Any ideas?

1 Like

Try renaming the folder core/packages/tinymcerte-2.0.9-pl to core/packages/tinymcerichtexteditor-2.0.9-pl.

There seems to be some confusion with the package name.
The transport package has the name but the folder inside it has the name tinymcerte-2.0.9-pl. I believe this should be the same: Either both tinymcerichtexteditor or both tinymcerte.

1 Like

same issue here this worked

Hm … tried some times, now loaded the package again and the name of the package is now (instead of before). And now it was installed correct.Spooky …

Thanks for the report, I’ve passed it on to the team working on the Provider and we’ll get it fixed up!

1 Like

Everything works but for the extras which are unavailable in my manager that shows below error:

TypeError: count(): Argument #1 ($value) must be of type Countable|array, string given


  • /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\Processors\Workspace\Packages\GetList->checkForUpdates(object, Array ( ) ) in /www/webvol20/87/wukxzeiisxji9mr/
  • modDashboardWidgetUpdates->render() in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modDashboardWidgetInterface->process() in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modDashboardWidget->getContent(object) in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modDashboard->render(object, object) in /www/webvol20/87/wukxzeiisxji9mr/
  • WelcomeManagerController->process(Array ( ) ) in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modManagerController->render() in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modManagerResponse->outputContent(Array ( ) ) in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modManagerRequest->prepareResponse() in /www/webvol20/87/wukxzeiisxji9mr/
  • MODX\Revolution\modManagerRequest->handleRequest() in /www/webvol20/87/wukxzeiisxji9mr/

I have seen other cases where people had this problem.
On some installations there seems to be a problem with reading data from the package provider API using cURL.

As a temporary workaround you could set the system setting auto_check_pkg_updates to No. This doesn’t fix the issue, but you should see the list of the installed extras again.

Also maybe take a look at these similar topics:

1 Like

halftrainedharry, your tip worked like a charm :slight_smile:

This should be resolved now. The recent updates to the provider introduced a new format of error message and it was missing an expected element in the package manager code inside of MODX.

Hi Jason,

Thanx for your answer.

So how do I Get this “update”?

The update was to the package provider service. You do not need to do anything. However, it seems that something is still wrong with certain packages and I am trying to determine what it is specifically.