Files > Filesystem: Not Displaying Directories or Contents

Filesystem in MODx 3.0.1 site is not showing my Assets Directory, which also contains, CSS, JS, Images, etc. I am not using any special characters, so the post I found regarding this issue did not apply.

Any symlinks in the directory by chance?

Checked the modx error log?

No symlinks that I can find. Just updated from 3.0.1 to 3.0.2. No errors other than the issue with loading modmore, which was actually because it already loaded, and in a sense I was unknowingly attempting to load it twice. :slight_smile: The only other error is related to a missing snippet, which I am fixing now.
Is there perhaps something I need to change in the system settings? Can’t say I ever had this problem before. Sidenote here though… I did edit the htaccess to prevent directories from being visible to the public. I have always done this, and used the same rule, without any issues. I use Options -Indexes
Do I need to use different directory for Assets? The current one also contain Components, which now contains the formit, and redactor. Redactor is working great. Still working on my form.

Can you show a screenshot of your media source configuration?

Thank you Mark for jumping in to assist on this.

The Safari Web Inpector shows an error: Failed to load resource: the server responded with a status of 500 ()

This is a link — which loads the following when I click on it.
{“success”:false,“message”:“Access denied.”,“total”:0,“data”:,“object”:{“code”:401}}

I meant Media > Media Sources > the configuration of your media source. :wink:

This suggests it is encountering an error. It’s a bit tricky to debug but if you open the developer tools on the network tab, look at the requests that get sent when you try to expand the file tree, especially the one with the 500 response code. Look at their responses to see if there are any errors there. If the response is empty, you will need to look for the PHP error log.

Just following a link to the connectors directly will always return an access denied error because that lacks the access token. So that’s expected.

Also to confirm, htaccess limiting front-end access doesn’t normally affect listing files/directory.

So even empty it doesn’t show anything in the files tab? I’d assumed some sort of configuration issue but clearly this is something else.

Did you try to inspect the connector response like I mentioned?

Spent some time with this last night. The htaccess file issue has been corrected. My ReCaptcha V2 extra has been corrected. There are no errors in the MODx manager error console. The Resources and Elements Tab display all of their contents. The Files tab only displays the top level directory “Filesystem” and no contents are visible in the manager. My one page I was working on works fine, indicating that all paths to the various needed css, js files, etc are functioning properly. When I click to recycle that Filesystem item, Safari web inspector returns: [Error] Failed to load resource: the server responded with a status of 500 () (index.php, line 0). I have cleared my browser cache. Also deleted contents of core/cache. Also tried creating a separate admin user (saw this on a separate sort of related post)… but even that did not work. The Files tab is just not displaying contents. :frowning:

Resource Tree Works. Elements Tree Works. Files Tree yields the following error in Web Inspector.
[Error] Failed to load resource: the server responded with a status of 500 () (index.php, line 0)

I have 3 extras. Could one of those be causing an issue?

Please follow these instructions to debug the 500 response code and getting to an error message:

As for this:

Highly unlikely. I don’t know of any extra (beyond custom media source types) that interact with this level of rendering the file tree. This may be a new bug or some kind of server issue that’s not yet known.

So that means we need some technical information to figure out what’s going on.

I’m happy to try and help you figure out the problem this way, but if you just want it solved already, email to book premium modx support (paid service).

Thanks Mark — I copied the only link that appear with the 500 code and pasted into a new window. There result is: {“success”:false,“message”:“Access denied.”,“total”:0,“data”:,“object”:{“code”:401}}

If I simply click the link in the inspector, i get: An error occurred while trying to load the resource.

Viewing in the Network tag… the last item is in red, and I have no idea what that is. :slight_smile:

No Errors occur in the manager error log. I cannot find any errors in cPanel error log.
I installed via Softaculous, and then also did the update to 3.0.2. Would it be beneficial to do a manual re-install? Can I do this without losing the work that I have done thus far?

I will use the paid support. However, before doing so, I will load MODx to another domain for which I will be creating a much larger site. Will know shortly whether the issue is isolated to my current project, or will the MODx install in general. I really appreciate you jumping in to provide some assistance. Thank you tons!

It’s hard to tell if a reinstall will help without knowing the cause for the 500. It can literally mean a million different things, so it might help but it might not, and is just a stab in the dark. In my experience working on getting an error message is the number 1, 2, and 3 priority at this stage.

Try adding this to the top of connectors/index.php, that’ll sometimes help show an error in the Ajax response (which now just shows the red “an error occurred…”).

ini_set('display_errors', 1);

Keep a backup of your database to make sure you don’t lose anything if you do go the reinstall route.

Thanks Mark. I will give this a try. My host — SkTst — just emailed back that Softaculous does not support the latest MODx… which is odd because that is how I installed 3.0.1 and also updated to 3.0.2. I have sought confirmation on their statement and am awaiting a response.

Inserting the code not working. I may not be inserting it correctly though.

I just did a clean, fresh, Softaculous install on a different domain, and have not yet loaded any content. The same problem is ocurring. File tree is empty, and the same 500 web inspector code is being generated. There are no errors showing in the manager error console.

This is may be a long shot, but something that used to cause a lot of trouble for me is folder and file permissions – often on various hosting services they would be set to the wrong permission structure for MODX to function correctly. Especially when using something like Softalicious (Softaculous? Whatever it is…) to handle the installation.

I don’t remember off the top of my head what the permissions should be, since I’ve been using MODX Cloud I don’t have to worry about it anymore. Hopefully someone will pop in here and tell you or you can do a search yourself and find the correct numbers.