Cannot save ressource with intern link like [[~10]]

After update to modx3.0.2 I have the fact that a ressource with an intern link like [[~10]] to an other ressource will not save. Saving starts but is running for minutes and than I break it. The ID already exist.
Other changings in the same ressource I can save.
I think the problem depends by the intern link.

I got Error message like in following post
after uncommending the lines in /core/model/src/Revolution/modLinkTag.php the errors are gone but the problem is still there.


ressources with intern link will not save

Step to reproduce

update to modx 3.0.2 php8.0
check for double ID’s - no double ID’s or alias

Observed behavior

How it behaved after following the steps above. Annotated screenshots here are excellent.

Expected behavior

saving of ressources with intern link


modx 3.0.2 PHP 8.0

Saving a resource in the manager just saves the resource content as it is.
There is no syntax check or anything.
(The tag [[~10]] only gets parsed when the resource is requested on the frontend.)

So if saving doesn’t work, then there is either a custom plugin interfering (events OnBeforeDocFormSave and OnDocFormSave) or maybe the firewall on the server blocks the request.

The problem is since the update.
New resources without intern links I can save.
Just new resources with an intern link will not save, extern links are no problem.
So probably, there must be a error in the system.
The resource I try has an chunk with a getresources call.
At an other new resource (after upddate) I have the same problem, just when I set a link in the content.
Older resources with intern links are ok, but If I want to change anything in those resources, I can not save.

I very much doubt that.

Take a look at this thread. It’s probably the same issue:

Thank you for the link to the other thread.
It really sounds like the same problem.
I also changed editor, with no result.
In the error-logs of the server I can also find the error code 403.
So I will contact my hoster and hope it will solve the problem.

My german provider “dogado” has a very restrictive firewall. There is a hint in the firewall settings: “Atomic Advanced (purchased via Plesk) running on Apache (ModSecurity 2.9)”.

I can look in the server error protocol to find the safety rule id for every error. This id can i put into a white list. That helped in my problem.

Problem is solved.

I had contact to my provider and for two error logs at the server he has given permission.
Now I can save resources with intern links.

Thank you for help.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.