[Solved] 3.0.3: Can't set links in richtext anymore

Since the change of the modx.tabs.js I can’t set links in a richtext field.

Normal text with and without formatting (bold, italic, list etc.) is ok, I can save the document after editing. But if I set a link in the text saving fails. I only see the progress bar (looping).

Tried to set back the compressJS setting: same result.
Tried both TinyMCE Editors from Extras: same result.
Tried other browsers: same result.

Seems to me that 3.0.3 is an unstable version this time?

(And YES: I cleared browser cache, core/cache, cookies and so on every time …)

EDIT: 2 errors in developer tools after clicking “save”:

POST https://www.my-affected-domain.de/connectors/index.php 403
VM2644:1 Uncaught SyntaxError: Unexpected token '<'
    at doDecode (ext-all.js:21:49686)
    at Object.decode (ext-all.js:21:51149)
    at Ext.form.Action.Submit.handleResponse (utilities.js?mv=303pl:375:21)
    at Ext.form.Action.Submit.processResponse (ext-all.js:21:582662)
    at Ext.form.Action.Submit.success (ext-all.js:21:584300)
    at n (ext-all.js:21:49005)
    at Ext.data.Connection.t (ext-all.js:21:49092)
    at HTMLIFrameElement.A (ext-all.js:21:52931)

EDIT #2: did the upgrade installation again: same result. Can’t save a document with a link in a richtext field.

Can you change to the “Network” tab (in the developer tools) and check what is in the response of this request that fails?

The response in network tab is:
Name: index.php (/connectors/index.php)
Status: 403

If there isn’t a stable solution for 3.0.3 problems: is it possible to simply revert to 3.0.1? Only via update installation of this version? Or do i have to consider other things?

@halftrainedharry Important note: I can link to an internal file in assets oder to an external URL without problems, but never to an internal resource [[~123]]!
The internal linking results in an 403 error (forbidden).

I installed TinyMCE Rich Text Editor (2.0.9-pl) on MODX 3.0.3, but I don’t have any problems saving a link.
So it might not necessarily be a problem with core MODX.

Did you only upgrade MODX or other extras as well? What version of MODX was it when it still worked?

My guess is that maybe a plugin (from an extra) creates an error. Can you (temporarily) deactivate plugins that run on the event OnDocFormSave (and OnBeforeDocFormSave) and see if that helps.

There is a tab “System Events” on the system settings page (manager/?a=system/settings) where you can see which plugins runs on what event. (Use the search field to filter.)

I don’t think you can revert back to older versions. (Only if you have a backup that you can use.)

I have tried both TinyMCE Rich Text Editor (2.0.9-pl) and TinyMCE (4.3.4-pl, this was installed first). Both extras have the same problem.

I only have updated MODX itself, from 3.0.1 to 3.0.3. All installed Extras were up to date before and after the update without any own updates.

OnBeforeDocFormSave runs only with Collections.
OnDocFormSave runs only with Redirector.

Deactivated first one, than the other, than both: nothing helps, can’t save the document.

The request that returns the 403 error.

Is there something in the response tab?

What is the value of the action parameter (in the “Request” tab)?

Spooky. The response tab shows a source code of an error page with the error 403, text is in German and in English.
And there is no request tab. I have “Headers|Payload|Preview|Response|Initiator|Timing|Cookies”

Yes, in Chrome it looks a bit different.
Take a look at the “Payload” tab. Is the action “Resource/Update”?

I’m really lost here. No idea what causes this.
Can you save content with the tag [[~123]] on a resource where the richtext setting is set to 0?

Yes, there is action: Resource/Update.

Nope, can’t save. But now there is another richtext field despite the richtext being switched off in the settings tab??

EDIT: a crazy thing. I put plain HTML with a link in the text (link with modx tag) in a textarea field (and the richtext setting is off for this document). And I can’t save this document!

EDIT2: set the document to richtext=off AND deactivated the TinyMCE plugin. Then put the plain HTML with a [[~123]] link in different fields. Can never save the document …

My guess is, that a firewall of the server blocks the request.

If a request is so randomly blocked and returns a strange error message, I can’t think of anything else that causes this.

But with 3.0.1 it worked …

Tried this linking in richtext field at an other server with a 3.0.3 update. There it works. Must be a problem with this server/provider. And I don’t know why …

It’s sometimes hard to say what triggers a firewall.
The error message you get in the response, is it definitely not from your MODX page?

1 Like

Ah, I should read the whole message first.
Yes the error message is definitely from the provider/server. And the problem IS a firewall:

### Error 403: your request was denied

Possible causes for this error are:

* No index page (e.g. index.php or index.html) was found
* Your request was denied by our web application firewall. In case you are the operator of this website, you are able customize or disable the Web Application Firewall in our control panel [xxxxxxxxx](https://xxxxxxx.xxxxxxxxx.org:xxxx/).

Today I was able to solve the firewall problem with the help of provider support.
Many thanks to @halftrainedharry for your helpful hints and pushes to the right direction! :+1:

1 Like