MODX Community

Why is TinyMCE so small as template variable?

I’ve a site where I’ve set a template variable for Rich Text and TinyMCE is the default. The RTE is display quite small compared my other sites. I’ve got dozens of sites. This happens on one or two others also.

Can any tell me how get this to display the normal size?

Modx: 2.7.1
TinyMCE: 4.3.4

See image.

2019-06-26_1444

Have you tried dragging the corner? I think TinyMCE remember the size, but I could be wrong.

There are no dragable corners.

I used to have that, but updates to both TinyMCE and MODX had fixed it (I thought anyway). I found that sometimes the JavaScript used to set the TinyMCE table width didn’t always fire, mean that the default style was ‘width: auto;’. For the TV area, that meant a smaller editor.

I’ve put in a custom CSS file for the manager which handles some of the quirks.

EG

.defaultSkin table.mceLayout { width: 100% !important; }
.defaultSkin iframe { height: 400px; width: 100% !important; }

Note that setting the width to 100% !important will mean you will not be able to manually resize it smaller. Also, if you use a different skin like ‘cirkuit’, then the class will start with ‘.cirkuitSkin’ instead of ‘.defaultSkin’.

And yes, TinyMCE is meant to remember the resizing of the editor, but for some reason you don’t have the resize bars available. Not sure if this is a setting for TinyMCE or a browser quirk.

1 Like

Great thinking, and just to make it a bit more obvious, how will this custom css…oh wait you just link it in your head section?

Possibly nevermind… :crazy_face:

I created a simple plugin which listens to the OnRichTextEditorInit event

switch ($modx->event->name) {
    case 'OnRichTextEditorInit':
        $cssFile = '/manager/assets/overrides/overrides.css';
        $modx->regClientCSS($cssFile);
        break;
}
return;
1 Like

Also from your screenshot it looks like you’re not using the newer TinyMCE.
I’d recommend this one instead:

2 Likes

I just installed TinyMCE 4. Once done, I was no longer able to edit any pages with the manager. When I have time I will try the other suggestions.

Thank you!

1 Like

Hi, when you say you couldn’t edit any pages, do you mean:

  • TinyMCE was not appearing?
  • it wouldn’t save?
  • the whole page wouldn’t load?
  • something else?

Cheers :slight_smile:

1 Like

Sorry, I should have elaborated.

When try to edit a resource, it get a 500 error. I tried this on another test installation I have and experienced the same problem. Perhaps it is conflicting with the version I just uninstalled?

I uninstalled the previous version, left it in the grid, cleared the cache and installed the new version.

1 Like

Sorry for the delay in getting back to you. (Long weekend here in Hong Kong!)
If you’re getting a 500 error then you should get a more detailed error message in either your MODX error log or your PHP error log.
Could you have a look there and let us know what it says?

1 Like

Which browser are you using? have you tried switching with different ones?

1 Like