Website only show's data from content field. Nothing else, no template, no html, no images, no css [SOLVED]


My website using MODX only show’s the data from the content field. There is no HTML build in the HTML source.

So I only see a white page with black content, without any HTML.

Step to reproduce

My MODX install is using multiple resources for serving multiple domains. I’ve tried

  • Uninstalling all plugins
  • Deleted cache from MODX & manually using FTP
  • Refreshed URI


Using latest MODX version 2.7.1-pl
PHP 5.6 / 7.2
Direct Admin
PHPMyAdmin 4.8.5:

  • Server: Localhost via UNIX socket

  • Servertype: MariaDB

  • Serverversie: 10.2.13-MariaDB - MariaDB Server

  • Protocolversie: 10

  • Apache/2

  • PHP-versie: 7.0.28

It looks like the template is set to blank(empty) Or that something prevents the loading/parsing of the selected template

If the template is set properly, but it still doesn’t render, it is possible you’ve restricted access to the element categories with ACLs. Had that a few years back, took me months to figure out why my sites was sometimes broken…

1 Like

Dimmy, I have set the right templates.

Thanks Mark, that might be in the right way to find where the problem might be. But whatever I change, still no webpage. I have set three options:
User Group | Authority | Access Policy
(anonymous) | 9999 | Load Only
Administrator | 0 | Administrator
Redacteur | 3 | Content Editor

I tried everything. Nothing seems to be working. The strange things is, I have multiple websites running on one MODX install, all the other are running fine. But not the one I’m working on.

[2019-06-06 17:20:17] (ERROR @ /home//domains/.net/public_html/core/model/modx/modparser.class.php : 541) Could not find snippet with name Wayfinder.

I’m not even using wayfinder and uninstalled the plugin.

[2019-06-06 17:20:17] (ERROR @ /home/***/domains/***.net/public_html/core/components/phpthumbof/model/phpthumbof/phpthumbof.class.php : 379) [phpThumbOf] Could not generate thumbnail: //******.jpg - Debug: Array

You’ve probably done this already, but make sure the template has all necessary HTML tags surrounding the [[$content]] tag, then cut and paste the template into the W3C validator and make sure it’s valid.

See if changing the Redacteur group’s Policy to Administrator then flushing permissions and logging everyone out solves the problem. If so, some permission is missing from the Content Editor policy (view_template?).

It’s also possible that this is a mod_security problem. Try making a trivial change to the template and saving it. Then reload and see if it’s changed. If not, mod_security is probably messing with you.

Are you using the FastField extra? That can cause the snippet not found error.

1 Like

Thanks Bob,

Yes the HTML is valid, since it was working. From the context, under the access permissions tab, I’ve removed the other group (redacteuren). Logout all users. Still not working. It’s so strange, sometimes a page works, when I save a page (without changing code) the white page pops up again.

No I don’t even know what it is. I also try using less plugins.

Do users have to be logged in to see the front-end pages?

Could there be a call to Wayfinder left in your template or a chunk included in the template that’s crashing things because Wayfinder is not installed?

Are you previewing from the Manager? That puts you in a weird position, permission-wise. View from another browser where you’re not logged in to the Manager.

A few more things to try:

  1. Create a minimal Template with just html, head, and body tags. in the body, put a tag for one really simple chunk (<p>hello</p> – no MODX tags) and the content tag. View a page that uses that template.

  2. Turn on Dev. tools in Chrome or Firefox (Ctrl-shift-i) and watch the Network tab as you load pages.

  3. See what’s in the resource cache (core/cache/resource).

  4. Try disabling all plugins (right-click on them in the tree) and manually deleting all files in the core/cache directory. If that works, bring the plugins back one-by-one to see which one is causing the problem.

1 Like

Thanks Bob, I’m getting somewhere.

  • I removed Wayfinder tags from the header chunk. Nothing new happens.
  • Some pages do load in a private browser when I’m not logged in to the CMS.
  • I checked in the inspector [Network] tab, nothing special there. It only show the document status 200
    and on a subpage in [Network] tab a document and 500 status. While a few minutes ago, the subpage was visible and page 24 & 26 not.

Now here comes the interessting part… two pages only show the content and no HTML, not even when I add some simple HTML to it like you say.
In public_html/core/cache/resource/racer/resources there are two files:

  • 24.cache.php
  • 26.cache.php
    Both are the homepages (ID 24 & ID 26 in MODX) ID24 is the coming soon homepage (live) and ID26 is the DEV Homepage on my live MODX install.

Anothere strange thing happens…

Here the situation:
A Firefox (logged in to manager) is open on a subpage is visable but not the page 24 & 26
B Private Firefox (not logged into manager) is open and two subpages are open.

1 - I change 1 letter in page 26… I refresh B and the error happens, I only see a white page.
2 - I go back to browser A and I refresh the page using F5
3 - I refresh subpages on browser B and there visible again.

I blows my mind really.

It’s weird all right.

My guess now is that it’s a bad plugin that fails in certain circumstances (unless you’ve already disabled all of them), a file permission problem with the cache directory, or a problem with the server (especially if it’s running some kind of server cache or accelerator).

A look at the server error log might be in order.

How did you install MODX?

1 Like
  • I’ve disabled all plugins except Xrouting since I run more then one website on 1 install
  • Cache folder permission is set to 755
  • I run on shared hosting and the other domains/websites running on the same MODX install run ok
  • I’ve installed it by uploading a zip and unpacking. But it used to work so I don’t think that is the problem.

In the error log:

[2019-06-07 00:01:50] (ERROR in xPDO::getService @ /home/***/domains/***.net/public_html/core/xpdo/xpdo.class.php : 1234) modRestClient::__construct is deprecated since version 2.3.0. Use the modRest classes instead.

PS thank you so much already for your time.

I’m afraid I haven’t been much help, but thanks for the kind words.

That’s the MODX error log, and that error is not related to your issue (it’s just a deprecation notice). Have you looked at the server log?

Another thing to try would be to install the UpgradeMODX extra and then set your settings_version System Setting to an earlier version. That will let you “upgrade” to the version you already have. You’ll get all new versions of the MODX files, the cache will be fully cleared, and setup will get run again.

1 Like

When I copy the code from the template to the content field (disabled rich text) the main index pages seem to be working.

It’s work around I do not want to work with, because I should also work like this for all the articles.
So the error seems to be linked to the templates somewhere. But it’s hard to say, because the white screen doesn’t alway occur. Or maybe chunks don’t like to be in Resources templates…? Reading article about it on the old forum. And maybe this is a solution adding &idx=[[+idx]] to the resource code.

Chunks are used in templates all the time, so it’s definitely not that.

It’s more likely a caching issue. Can you paste your template here (put three back-ticks above and below it to preserve the formatting)?

1 Like

Template for Podcast afleveringen


		<!-- ===== LASTEST PODCAST (HERO) ===== -->
		<section class="podcast-hero" style="background-image: url(//; background-size: cover; background-attachment: inherit; background-position: center center;">
			<div class="podcast-hero-inner">
				<!-- ===== PODCAST INFO ===== -->
				<div class="container">
						<div class="podcast-hero-content">
						<h2 class="podcast-hero-title">[[*longtitle]]</h2>
						<ul class="podcast-hero-meta">
							<li class="item">[[*introtext]]</li>
		<!-- ===== MAIN ===== -->
		<main id="main" class="main">
			<!-- ===== PODCAST LIST ===== -->
			<section id="#episodes" class="section-positive">
				<div class="container">
					<!-- ===== SECTION TITLE ===== -->
					<div class="row">
						<!-- ===== PAGINATION ===== -->

						<div class="col-sm-12 text-center mb-50">
<!-- ** plugin installed
							<ol class="pagination">
								<li><a href="#">1</a></li>
								<li><a href="#">2</a></li>
								<li><a href="#">3</a></li>
								<li><a href="#"><i class="fa fa-angle-right"></i></a></li>


You’re missing a closing div for main. It looks like you meant to remove it completely

maybe its closed in the footer

I don’t see a content tag, and as nuan88 says, the main tag is unclosed unless the closing tag is in the footer chunk (which it really shouldn’t be, imo).

I don’t think using the [[+idx]] placeholder for the value of the &idx property in the getResources tag makes sense. getResources replaces that placeholder as it executes, but only when it’s used in Tpl chunks. The placeholder won’t have any value when the getResources tag is parsed. The [[+idx]] property is just used to set the initial +idx value (in case you don’t want to start at 1), which is incremented for each resource processed --its value should be an integer, not a tag.

Also, AFAIK, there is no &isTV property (unless it’s undocumented). Did you mean to use &includeTVList ?

I guess we also need to see the header and footer chunks.