Upload of this filetype is not allowed

Summary

Trying to upload an image through the manager, either into an image folder directly, or into a media source

Step to reproduce

Image upload–either through a TV or right-clicking on the folder in the File Tree. Selecting the file.

Observed behavior

Once the file is selected the message appears: “Upload of this filetype (.jpg) is not allowed”

Expected behavior

File should able to upload

Environment

REVO, 2.7.3 NGINX, multiple browsers. This is an older site on the same server as many others (no issues with them). The server settings are fine and haven’t changed.

I checked all System Settings, Media Source settings. Files can be SFTP’d. I know this was an issue years ago with previous versions of Revo (2.2). I cleared the cache and went into the System and Media Source settings and re-entered the allowable filetype. No caps in the files. Logged in, logged out. No luck.

Next for me is to upload the setup folder and run install again (nine months after it was last done), but I’d rather not do that unless there are no other options. Any other ideas?

If the system and media source settings are all fine, I’m also out of ideas.

In terms of rerunning the setup, you should be fine (if no core components have been edited directly). Just make sure you run the setup of your current version. I would then also recommend to upgrade your install, I use UpgradeModx which makes it very easy and automatically selects all needed versions in between.

I’ve run unt this in the past and I’m trying to remember what it was. Are you using any ACLs or more than one context? EDIT: from memory, the problem I had was with setting a value in allowedFileTypes in my media source. I’d tried to add a particular file type in there but didn’t realise that if I did that, it would override the system settings - in other words all file types needed to be set, not just an extra one. It sounds like you’ve covered that though.

It’s not a permanent solution, but if you just need to plow through this in the meantime connecting to SFTP through Filezilla always allows you to upload whatever you want to the server

Thanks, brittislove, I know that works, I just don’t want the client to do it.

ChrisAndy, not an ACL issue. I have the same problem with my admin account.

That message looks like what you get if the upload_files or upload_images System Settings don’t contain jpg.

A context setting, user setting, or a snippet or plugin property with the same names, would override the System Settings.