Unable to save css files

Hi Folks

Has anyone come across this issue?
I’m able to save chunks and other elements but when I try to amend the css files I cannot.
I’m using the cssSweet extra, which up until now has performed as it should.
When I attempt to make a change, the save function kicks in momentarily.
However when I go to Manage > Clear Cache to trigger cssSweet, things just hang.
On refreshing the page, the css file, unsurprisingly, remains unchanged.
I’ve tried a few things…
Clearing out cache,
Adding a variable after the css url.
Ensured the extra was up to date.
There are no errors showing.
My host tells me there are no server log mod_security violations.

Currently using Modx 2.8.6

Any help would be appreciated

Many thanks

I’ve had this on a few occasions especially after the host has upgraded or moved servers. Check file permissions, uploadable file types and make sure the file types haven’t been surpassed by allowedFiletypes in your media source. If you’re with 1 2 3 reg - they may have moved servers without telling you.

Some more possibilities:

Make sure the upload_files System Setting includes css files.

It could also be an issue with mod_security.

Thanks chrisandy
File permissions in good order
Uploadable file types still includes css

make sure the file types haven’t been surpassed by allowedFiletypes in your media source

Not so sure what you’re suggesting there…
The allowedFiletypes field was empty.
I added ‘css’ which made no difference.
I removed it again.

Thanks Bobray
As mentioned, upload_files still lists css.
My host has told me there was no mod_sec issue.

So no joy as yet.

Save the contents somewhere and see if you can save the CSS file when it’s empty.

…the setting there can override the system setting so best left blank

When you open the developer tools in the browser and run “Manage → Clear Cache”, are there any error messages in the “Console” tab? Any errors that are returned by the requests in the “Network” tab?

Hi Bob

Yes, the file indeed saves when empty.
I’ve double checked directly through the remote CPanel that the file is empty. It is.
However, despite clearing core cache, those ‘now missing’ styles still persist!

Hi Halftrained

When I go to ‘Manage > Clear Cache’ I get the following error in the console

Failed to load resource: the server responded with a status of 403 

Intermittently I also get the potentially more problematic
'...status of 500'

The fact that you can save it empty almost always means it’s a mod_security issue, in spite of what your ISP says.

mod_security sometimes balks at a single word (one use couldn’t save any file containing the word “casino”, so it would most likely be a class name in the CSS file or something that might look like an injection attempt. The issue could also be in the URL of the Manager page that you saved it from, though I think that’s less likely.

I’d suggest a binary search of the doc to see if you can figure out what might be triggering mod_security. Try deleting half the content and saving it. If it saves, restore it and delete the other half. Continue splitting it like that until you’re down to a few lines. Then look for a word that might be suspicious (or do that first if there’s an obvious one).

Hi Bob

Ok, I’ve worked through your suggestion and the following style is the culprit that refuses to save.

.header-new {
              background: url("../../../Image-Library/header-paintings/daub440.jpg") 50% 25% no-repeat; 
              background-size: cover;

If anything, perhaps the word ‘daub’ is a little unusual.
However, renaming it ‘picture440.jpg’ has made no difference.

It’s strange though as this has just recently come to light and has worked fine without issue.
I will go back to my host with this new info.
otherwise I’m at a loss here…
but many thanks for your time.
Much appreciated

HTTP response status code 440 Login Time-out is an unofficial client error specific to the Microsoft IIS web server. It requires the user to login again, so you might try changing the 400 to a value that’s not an HTTP error. Also, there’s a chance that the old name is still in your browser cache or the MODX cache.

Ah, the ‘440’ seems to have been at least part of the problem…
(of course I should have clocked and avoided that).
So a file name/css rule amendment has allowed the file to save.
But, like I say, the previous styles persist.
And as you suggest this looks like a cache clearing problem.
The browser cache has been cleaned endlessly.
But, as mentioned, the Modx Clear Cache seems to get to a point and then simply hangs…
ie the new styles are failing to update.

Might the following have any bearing do you think?

Failed to load resource: the server responded with a status of 403 

Try the CacheClear extra, and the Classic Cache Killer add on for Chrome.

Another quick thing to try – Add this on the end of the URL of a page:


Changing the number should give you a fresh page that’s not from the cache. I’m not sure it will affect CSS, though, if it’s still in the browser cache.