The problem with non-Latin header resource names MODx 3.0.0

Summary

I have template names that are used on the site that contain non-Latin names (Cyrillic, etc.), after updating them it became impossible to edit

Step to reproduce

Go to the resources, create a template with a non-Latin name. You get the inability to edit. UTF-8 encoding was used

Observed behavior

Expected behavior

Normal characters, not question marks, should have been displayed and the content edited.

Environment

MODx 3.0.0
PDO support:

enabled

PDO drivers:

dblib, firebird, mysql, pgsql, sqlite

PDO Driver for MySQL:

enabled

Client API version: mysqlnd 7.4.16

Directive: Local Value,Master Value

pdo_mysql.default_socket: /var/run/mysqld/mysqld.sock,/var/run/mysqld/mysqld.sock

default_charset:
UTF-8

I can’t reproduce this problem.
Was is the collation of your database?

mysqlnd 7.4.16. It has happened after updates from 2.8.3… I had several templates with name “Главный template”, “Статья с тегами”

I was interested in the collation or charset of your database. Something like utf8mb4_general_ci or latin1_swedish_ci.

As i wrote, I can’t reproduce the issue.
This doesn’t seem to be a general problem, but something specific in your setup.

Screenshot 2022-04-03 at 13-33-17 Шаблон Статья с тегами MODX Revolution


If you look at the values directly in the database (table modx_site_templates). Are the values in the column templatename correct?

utf8mb4_unicode_ci
UTF-8 Unicode (utf8)
Apache/2.2.29 (Gentoo) mod_dp/0.99.7 PHP/5.6.40
libmysql - 5.6.43-84.3
The names in database incorrect too

If you fix the names directly in the database, does it work then?

Yes, but there can be a lot of such elements, why didn’t the conversion take place fully?

What did you do before the problem occured?

  • Have you updated MODX from an older version? From what version?
  • Have you changed the collation of the database? How did you change it?

2.8.2->2.8.3 then filling the site with content, then installing 3.0.0 as an upgrade. I did not change anything, as I put it during installation, and it remained

I tried to reproduce the issue again (including running the MODX upgrade), but everything works as expected.
It’s hard to say, what failed on your system, if I can’t reproduce it.

Does this only affect the table modx_site_templates or other tables with cyrillic content as well?


Does this mean you are still using PHP 5.6?
I think the required mininum is now PHP 7.2.5.

Hmm, strange, in the hosting settings Apache 2.4 + PHP 7.4 opcache and this is phpinfo