SPForm redirecting wrongly on POST


Quick summary what this issue is about.
Hi All. I’m an older user of ModX from the days of etomite (yes, that long). I’ve made a couple of sites and my small business homepage runs on it.
I thought it was about time I added a contact page that works.

I couldn’t get FormIt to work. The tutorials are just non-plug and play.
SPForm was meant to ‘just work’… which it did… but then it didn’t.

Step to reproduce

After trying different options with FormIt, I gave up. I then saw a post from Bob somewhere saying SPForm was plug and play. Amazing I thought. I tried it. The install failed, because I had a page with an Alias already called ‘contact’, so I renamed that page, uninstalled, and reinstall again. This time it worked.

I sent a test email to my self from my new empty blank tempated page. Yay!
https:\\mywebsite.com\contact\ (128)

It forwarded me to a newly empty blank tempated page sent myself an email.
https:\\mywebsite.com\thankyou\ (129)

Great stuff! Finally working.
So, I thought it should have the current site template. So I changed this newly created page (128) to have a template.

I hit submit, and it then it failed to send an email, and failed to forward be to the thankyou page. Instead, I got sent to this page which doesn’t exist:
with an error “Oops”. (404)

I’m on the latest versions.
MODX Revolution 2.8.6-pl
SPForm: 3.3.4-pl

This is what I’m using, as per the default.

    &recipientArray=`Webmaster :me@mywebsite.com`

<div class="spf_captcha_instructions">[[+spf-captcha-instructions]]</div>

<div class="spf_captcha_image">[[+spf-captcha-image]]</div>

<div class="spf_input_pair">
    <span class="spf_block_prompt">[[+spf-captcha-input-prompt]]</span>
    <span class="spf_normal_input">[[+spf-captcha-input]]</span>

Anyway, I don’t know why SPForm isn’t working. Any help would be great. :slight_smile:

Good news. I ended up getting FormIt finally working and so abandoned my SPForm quest - after writing this post.

I’m glad you got something working. Did SPForm put anything useful in the error log?

Unfortunately I didn’t turn logging on - just the onscreen debug, and what was logged - in the general log - didn’t show anything either.