Site Status set to yes won't display website

I’m running the latest MODX 3 and I’ve noticed that setting site_status to yes won’t make the site active.

I have site_start set to a published resource, so I’m not sure if I’m missing another setting to make this active on the front end.

I’ve also tried clearing the cache, clearing my browser’s cache, reinstalling MODX 3, checking my .htaccess…

Any ideas of what I’m missing?

Hi and welcome!

Do you see your site_unavailable_message when you try to browse the site? Or something else?

Can you browse the site OK as an administrator [when logged into the Manager in another tab]?

1 Like

Yes, the site unavailable message shows, and yes I can browse the site logged in.

Do you use Resource Groups / User Groups to restrict some content from non-logged in users?

In particular - you could check that your site_start Resource ID: 32 is not a member of any Resource Groups:

Just checked it and it’s not part of a resource group.

Tried a force cache clear (i.e. renaming/removing/emptying the core/cache folder)? The cache might just be stuck due to file permissions or something.

1 Like