Sending errors with Goodnews

i am using the goodnews extra for a website to send a newsletter once in a while.
After sending a news update today i noticed there were 55 send errors on 120 subscribers (respectively 3 on 114 last time). Does anyone know how to debug what these faults have been?
More then “send error” is not given. Logs provide no answers, even on the server the mail-logs don’t show any information.

Modx 2.7.2
Goodnews 1.5.1-pl2
Using SMTP: set to yes incl. auth. / set to no (tried both settings)

Who can help?

Hi mintnl,

same thing happened to my last sending process. 150 of 260 emails had an sendingerror.
According to Help, the cron has to be started every minute.
I started the cronjob with server’s default settings every 10 minutes. The protocol showed that the next mails with success were send 10 minutes after error .
I’ll test that in my next newsletter.

Hi mintnl,

I tested the sending again. My cron starts every 60 seconds. Nevertheless, I had again 83 errors on sending 260 emails.

Sorry for my late response! Just stumbled across this posting …
It would be good If you add the @gadgetto tag to such posts so I’ll get a notification.

May I ask you which provider your site is running on? Is it a shared hoster?
We had a lot of problems when using GoodNews on shared hoster platforms. Some providers are blocking excessive mail sending. Some are restrictive when using PHP exec commands.

The symptoms you describe indicate exactly such a problem. Especially if there are no entries in error log.

You could first try to set the amount of sending processes to 1 - this will disable multi threaded sending and omitting the PHP exec command.

thanks for the response. I had these problems with blocking a few months ago. But with support of hoster I was able to find the right settings to send mails.
They said that I can send 600 emails an hour without Problems. I think its a problem with cron. I will turn on debugging for the next newsletter.
In the log of the last sending process I noticed that mails are sent for 5 seconds (60 mails), then errors (30 mails) for 55 seconds, send again for 5 seconds (60 mails), 55 seconds errors (30 mails) again, etc.
Perhaps the cron with php is the problem. On the other hand, its possible that only 60 emails per minute / cronprocess can be sent.

I will report next newsletter …

This looks definitely like a provider limit!

I think so. But I don’t know how to change the settings.
Providersupport said, that 600 mails per hour can be send. That means 10 per minute or 1 every 6 seconds. I think I will test it with systemsettings of goodnews.worker_process_limit = 1 and goodnews.mailing_bulk_size = 1. If that’s not enough, I willstry for the containersetting setting_mailSmtpSingleTo = 1.

Depending on your server environment and provider, approx. 1 mail is sent per second. Assuming your cron job runs every minute, you could set:

  • “Maximum count of sending processes” to 1
  • “Mailing bulk size” to 5

This would mean that there will be 300 mails sent per hour.

You could also try to set “Mailing bulk size” to 10, which means 600 mails are sent per hour. Since this is however very scarcely measured, it could be, that a few mails are swallowed in this case already…

Status report:

i have just sent a new newsletter. That worked perfect with the settings of @gadgetto. :grinning:

Recipients Total 361
Recipients Sent 361
Sending Errors 0

Thanks a lot