MODX Community

Save Button for Resources Not Functioning

I am running version 2.7.3-pl and suddenly all the save buttons stopped working for resources. The saving doesn’t hang, the button just does absolutely nothing. I have tried on multiple browsers with extensions disabled and cleared cache, undid locks etc. Has anyone had this happen before?

Can you check in the browsers’ developer tool for any errors in the console?

Yes, but I have no idea how to fix it. I have cleared my browser cache, disabled all plugins, done the usual to eliminate browser issues. Tested Brave (shield off), Firefox & Safari (all mac)

Uncaught TypeError: Cannot read property 'hidden' of undefined
        at MODx.panel.Resource.failureSubmit (modx.panel.resource.js:251)
        at h.Event.fire (ext-all.js:21)
        at MODx.panel.Resource.fireEvent (ext-all.js:21)
        at MODx.toolbar.ActionButtons.handleClick (modx.component.js:298)
        at S.onClick (ext-all.js:21)
        at HTMLSpanElement.I (ext-all.js:21)

|failureSubmit|@|modx.panel.resource.js:251|
|---|---|---|
|fire|@|ext-all.js:21|
|fireEvent|@|ext-all.js:21|
|handleClick|@|modx.component.js:298|
|onClick|@|ext-all.js:21|
|I|@|ext-all.js:21|

[sorry for all the edits]

I also reinstalled with SiteDash and no luck.

Do you have access to another computer that you could try it on? Is it possible that you have any anti virus software that could interfere with the function of the manager. I once had an issue where Sophos for Mac prevented MODX from working correctly.

I do have Sophos installed, but I just disabled every feature and added the site to the whitelist and nothing. I don’t have access to another computer at the moment.

You have established by successfully testing on another site that the problem is not caused by your computer.

Do you have the following files referred to in the error message? And are the permissions for them and their parent folders correct?

/manager/assets/modext/widgets/resource/modx.panel.resource.js
/manager/assets/ext3/ext-all.js
/manager/assets/modext/core/modx.component.js

Can you use quick edit on a resource?
(right click >> quick update)

Yes I can, but that doesn’t do enough since I need to use ContentBlocks for much more complex editing.

I do have the files, folder permissions are 755, the files are 644.

Possibly mod_sec settings of your provider. I had the same problem / error.

1 Like

What do the people at Contentblocks (Modmore) tell about this?
Try to make a template without extra’s and see if that works?

If it’s running the failureSubmit method that suggests the save request didn’t complete as expected…?

@ShatteredSite, can you try inspecting the save request from the net/network tab to see what comes back from that? It’s a POST request to connectors/index.php with an action request parameter of resource/update.

At the moment I don’t suspect ContentBlocks to be related to this particular issue @voklee, but @ShatteredSite knows how to reach support. :wink:

I was just hoping you jumped in. You (@markh) have much more experiece than me… :slightly_smiling_face:

I can remember this same error a time ago. I did a fresh reinstall to an other location and it was solved. (other server specs) Never found the error…

If you can check the server logs or ask your host to. In my environment I get mod security rules that kick in and prevent saving in modx. I can’t access the server logs pertaining to the mod_sec. I have my host whitelist the domains that that happens to.

I just submitted a ticket regarding that.

So A2Hosting did come across an error with mod_sec and told me this:

We do have a firewall installed on the server and some mod_sec rules can trigger the firewall. We were checking your website and we noticed the following rule is being triggered:
[Tue May 26 07:58:04.086039 2020] [:error] [pid 1838:tid 47691947730688] [client 89.248.168.241:64076] [client 89.248.168.241] ModSecurity: Access denied with code 403 (phase 2). Operator GT matched 0 at USER:bf_block. [file “/etc/apache2/conf.d/modsec/modsec_a2/a2_xmlrpc_possible_attack.conf”] [line “13”] [id “5001”] [msg “89.248.168.241 blocked for 30 minutes, more than 10 login attempts in 5 minutes.”] [hostname “activatebody.com”] [uri “/wp-login.php”] [unique_id “Xs0ETJ6U0JsLLeha8soXrgAAAUY”]

They just whitelisted Mod_ sec rule id “5001”, but no luck.

The activity they are referring is not related to your site. It seems to relate to a Worpress site: activatebody.com

Thats whats odd, that IS the MODX site! No more errors are being thrown though. Kind of at a dead end of what I know how to do.

That is odd.

Does the problem affect all resources and all user accounts?

I notice in the sitemap.xml that one page is listed as being updated yesterday? Is it possible that the save button appears not to work, but actually the resource is saved?

<url>
<loc>https://www.activatebody.com/testimonials</loc>
<lastmod>2020-05-25T19:12:04-04:00</lastmod>
<changefreq>monthly</changefreq>
<priority>0.5</priority>
</url>