Revolution 3.0.2 Interface mostly blank after upgrading

I’m in the process of upgrading a number of sites from 2.8.4 to 3.0.2.

After un-hardening the first site, and jumping through a number of permission hoops, it finally installed. But now when I login only the shell of the manager interface loads. None of the content loads (see screenshot below).

The site itself is up and functional, but I can’t manage it at all. I’ve cleared the root cache as well as the core/cache, but nothing changed.

What am I missing? Thanks!

Are there any relevant error messages in the error log file core/cache/logs/error.log?
Any (useful) error messages in the console of the browser’s developer tools?

If one of the installed extras is not compatible with MODX 3, it sometimes helps to (temporarily) deactivate the plugins (database table modx_site_plugins → column disabled) and clear core/cache again.

Thanks for your help. I’m getting the following errors via /var/log/httpd/access_log:

  • GET /connectors/lang.js.php?ctx=mgr&topic=topmenu,file,resource,trash,welcome,configcheck&action= HTTP/1.1" 500

  • GET /connectors/modx.config.js.php?action=&wctx=mgr HTTP/1.1" 500

  • GET /manager/assets/modext/widgets/resource/modx.window.resource.js?mv=302pl HTTP/1.1" 404

  • POST /manager/undefined?action=system/dashboard/widget/feed&feed=security HTTP/1.1" 404

  • POST /manager/undefined?action=system/dashboard/widget/feed&feed=news HTTP/1.1" 404

I disabled my plugins, via the database, and dumped my core/cache/, but that didn’t seem to do anything.

I’ve also disabled all extras and plugins via modx_site_plugins and modx_transport_packages, setting disabled to 1. I then deleted the cache from core/cache reran the setup installer, all with seemingly no effect. The interface is still missing.

Have you tried visiting in private or incognito mode to eliminate the browser cache and cookies?

Thanks for the suggestion. I had cleared my cookies, but to be sure I just tried an incognito window…unfortunately the same thing happens. I’m able to login, the shell of the interface loads, but no resource tree and no content. Not even the news feeds load. I can browse the modx menus, but none of the buttons work.

Have you checked if the file /manager/assets/modext/widgets/resource/modx.window.resource.js exists?

As two of the requests return a 500 error: Can you check the PHP error log of the server to see if an error message gets added when you request,file,resource,trash,welcome,configcheck&action= directly?

Did you, by any chance, transfer the new MODX files individually with FTP? That often results in missing or corrupted files.

Well this is embarrassing, but I found the issue. It ends up I had only synced the core directory (and not connectors or manager). Sorry to take your time on this…but as always I’m very appreciative of your help. Thank you!

I’m glad you got it sorted. :slight_smile:

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.