Resources won't save after upgrading to Modx 3 - Endless saving loop

Upgraded from Modx 2.84 to 3.03 and resources won’t save. Just get the “Please Wait - Saving” message which goes on for ever. Tried so far… None of which worked

  1. Created a basic test resource with a base template. No template variables etc.
  2. Uninstalled all Extras
  3. Reverted to version 3.00
  4. Turned the log_deprecated system setting on and off
  5. Switched PHP versions from 8.1 to 7.4 just to test
  6. Checked access control list. All permissions selected

No real clues in the error log except… (which looks vaguely relevant)

@ /home/xxxx/xxxxx/manager/controllers/default/resource/update.class.php : 17) PHP warning: Class ‘ResourceUpdateManagerController’ not found

Anyone else have this problem and is there a resolution for it do you know?

Is there anything insightful in the developer tools of the browser?

Open the “Network” tab of the developer tools and then try to save the resource.
It creates a new request (with the parameter “action” = “Resource/Update”). What’s the response of this request?

Hmm, Here’s from the headers tab. The response tab is blank.

So the Status Code is “500 Internal Server Error”.

Can you check the PHP error log on the server (that’s not the log file from MODX) to see what the actual error message is?

[15-Jul-2023 09:49:59 UTC] PHP Fatal error: require_once(): Failed opening required ‘/home/xxxx/xxxx/core/components/simplesearch/model/simplesearch/simplesearch.class.php’ (include_path=‘.:/opt/cpanel/ea-php74/root/usr/share/pear’) in /home/xxxx/xxxx/core/cache/includes/elements/modx/revolution/modplugin/14.include.cache.php on line 37

Oddly enough, I’ve just discovered that if I wait for a few seconds and reload the page the changes do get saved. It’s just the “please wait - saving” message never goes away.

See attached. It looks like it might have something to do with the simple search plugin although I’ve uninstalled it?

Anything in the extension_packages system setting?

If SimpleSearch appears in there - try removing it.

The current version of SimpleSearch (for MODX 3) has no plugin. That’s probably a relict from an older version. Deactivate the plugin (or delete it) and check if that fixes the issue.

The SimpleSearch plugin runs on the event “OnDocFormSave”. So the error occurs after the resources has already been successfully saved.

The “please wait - saving” message just never goes away, because the request doesn’t return the expected JSON result ({"success":true, ...}) because of the fatal error.

Fixed it. I completely removed the plugin and all references to Simple Search (Sisea) in Name Spaces, Extension Packages, Snippets and Plugins in Modx + cleared the cache and it worked!

Thanks guys for your help. Much appreciated!

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.