Redirector not working on Modx 3


I have tried to install Redirector on latest Modx 3.0.1 and it fails. Records cannot be created in Redirector menu, contexts list is not loading there too.

* MODX Console Output
* @date 2022-05-02 19:30:24
Attempting to install package with signature: redirector-2.0.9-pl

Package preparing to install.

Grabbing package workspace...

Workspace environment initiated, now installing package...

Could not load class: modTransportPackage from mysql.modtransportpackage

Could not get table name for class: 

Error 42000 executing statement: 
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AS `latestPackage`
            WHERE `latestPackage`.`package_name` = `modTransp' at line 3

Successfully installed package redirector-2.0.9-pl

/* EOF */

Does this pull request fix the issue or are there additional problems?

Seems it does not help. Same error on install. Same error on create redirect page (Requested processor not found) while opening context list or resource list.

Try changing the L in getList to lower case in these 2 places as well:

Yes, this doesn’t fix the install error, but you can probably ignore it, if you don’t do an upgrade from an older version of Redirector.

That’s it, working now. How to fix installer ? and maybe put new release to extras repo ?

I created a new pull request with the additional changes: