MODX Community

Recaptchav2 No more functionning SOLVED

HI,

As we got more and more spam on our contact form that was using recaptchav2 with v2 keys, I just tried to add v3 keys and turn my chunks into v3 call.
Never worked (no communication error )
Trying now to fall back to the previous v2 does not work anymore.

I deleted the domain name V3 + V2 entries in Google captcha admin console and register again the domain as V2 and paste the 2 new keys in the system parameters of modx.

The click on the recaptcha is still in error “unable to establish communication…”:

Blockquote
impossible d’établir une connexion avec le service reCAPTCHA.Veuillez vérifier votre connexion Internet, puis actualiser la page pour afficher une image reCAPTCHA.

the chunk for this captcha:

		  [[!recaptchav2_render]]

[[-!recaptchav3_render?
    &tpl=`recaptchav3_html`
    &token_key=`token-1`
    &action_key=`action-1`
]]
		  <span class=" pt-txt help-block muted">Actual Visitor? Please check this.                                     
			</span>
	  </div>
  <span class="alert live"  role="alert">                                                    
			<span class="badge badge-warning">!                                       
			</span>&nbsp;[[%i18n.required? &language=`[[++cultureKey]]` &namespace=`i18ncustom`]]                                        
			<span class="label label-warning">Attention                                       
			</span>                                                
		  </span>             [[!+fi.error.recaptchav2_error:notempty=`                                 
		  <span class="alert">                                      
			<span class="badge badge-warning">!                                       
			</span>[[!+fi.error.recaptchav2_error]]                                 
		  </span>`]] 		    		
  </div>

the chunk of the form with the Formit call:
[[!FormIt? &hooks=recaptchav2,email,redirect,FormItAutoResponder &emailTpl=chunk_email_msg
&emailSubject=Contact from xxxxx
&emailTo=contact@xxxxxx
&redirectTo=54 &store=0
&emailUseFieldForSubject=0
&fiarTpl =autoRepContactmsg-en &fiarSubject=copy of your contact message on imchem.fr
&fiarReplyTo=info@xxx.fr
&fiarReplyToName=xxx
&vTextRequired=Please fill this field.
&subject.vTextRequired=Please enter a topic for your email.
&validate=name:required:minLength=2, tel:required:minLength=8, email:email:required, soc:required:minLength=2, subject:required:stripTags, text:required:stripTags, special_email:blank
]] [[!+fi.error_message:notempty=<p>[[!+fi.error_message]]</p>]]
[[- pour Formit param recaptcha v3
&recaptchav3.token_key=token-1
&recaptchav3.action_key=action-1
&recaptchav3.threshold=0.9]]

Thank for any help

So when exactly do get an error? When your try to check the “I’m not a robot”-checkbox?
Do you have an active ad blocker in your browser that blocks the connection to the google-api?

By the way: Your real domain-name is still visible in some parts of your post above.

Hi
Thank you

I decided to use v3. Somehow painfully but I finally got the contact form doing its job and a google captcha logo is added to the dom

Don’t know if it works but looks like.

So I’m closing this thread.

Look up reCAPTCHA Version plugin on Wordpress, it lets u choose v2 or v3. Works for me.

But then you would be stuck using Wordpress.

The reCAPTCHA extra for MODX lets you choose v2 or v3 too.

1 Like