MODX Community

Problems with getFeed: not getting the feed content

I’m having an issue on this page: https://www.bipc.com/blogroll

As you can see, two of the three feeds are working properly. The 3rd one is also a WordPress blog, but one that i recently updated. The feed itself works fine and i ran it through a validator too and it passed.

The code i’m using for this feed is as follows:

[[!getFeed? &url=https://www.buchananGovernmentRelations.com/feed/ &limit=3 &tpl=insightBlogRollFeedTpl]]

And the tpl chunk is:

<p class="topic"><a href="[[+link]]" target="_blank">[[+title]]</a></p>
<p class="meta">
<span class="date">[[+pubdate:convertRssDate2RightFormat:date=%b %e %Y:ucase]]</span>
<span class="author">[[+dc.creator]]</span>
</p>

The only thing different about the new site is the template, the new domain name and the SSL certificate i added to it.

Note: I also tried this with another website that I manage that’s completely different from this. It also doesn’t work. I’m wondering if the https might be an issue? I even tried using the url as //www.buchanan… and that also doesn’t work.

Any insight would be helpful.

Thanks

Anyone have any ideas? This just isn’t working at all. I also tried ParseX instead of getFeed, the feed worked, but the dates were wrong and the author field wasn’t populating.