Phpthumb manager issues, no thumbnails

I’m having an issue across multiple 2.8.x websites where media will not display in the manager.

Screenshot 2024-02-06 at 13.01.39

Screenshot 2024-02-06 at 13.01.46

These are the errors I get within the console when accessing the media browser.

Below is the server error log:

[Tue Feb 06 11:45:49.276188 2024] [proxy_fcgi:error] [pid 1490620] [client] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught TypeError: Argument 2 passed to phpthumb::__set() must be an instance of mixed, bool given in /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/phpthumb/phpthumb.class.php:317\nStack trace:\n#0 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/phpthumb/phpthumb.class.php(395): phpthumb->__set()\n#1 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/phpthumb/modphpthumb.class.php(84): phpthumb->setParameter()\n#2 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/modx/processors/system/phpthumb.class.php(117): modPhpThumb->initialize()\n#3 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/modx/processors/system/phpthumb.class.php(66): modSystemPhpThumbProcessor->loadPhpThumb()\n#4 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/modx/modprocessor.class.php(185): modSystemPhpThumbProcessor->process()\n#5 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/modx/modx.class.php(1770): modProcessor->run()\n#6 /home/storm/sites/xxxxxxxxxx-co-uk/public/core/model/...', referer:

I have many other Modx 3.x sites and they all running fine on the same server.

This specific website is on PHP 7.4 but I have other sites experiencing this issue on PHP 8.x

Could it be related to this?

The error looks the same although I think that issues was only reported against PHP 7.4

Thanks for the quick reply. I just tried and cleared cache etc but still the same error