Personalize conflict with notify

I m using MODX Revolution 2.6.5-pl with personalize-3.7.2-pl and works perfect. From the moment i installed notify-1.5.3-pl personalize stopped to react. After user login &yesChunk &noChunk stopped to work. It is strange from the moment that personalize is one of the requirements in order to install notify.
Do you have any advice?

Thank you in advance

@pakosfakos Are you seeing any errors in the error log or on your server’s PHP error log? I’m sure with more information @bobray will be able to help you debug your issues. Errors as mentioned above and also your server’s PHP version will help. Keep in mind that versions of MODX below 2.7.4 are not compatible with PHP8, this could also be causing issues if you host has updated your server. PHP 7.4 will be end of life on November 29, 2022.

Also, it would be a really good idea to consider upgrading to 2.8.x. 2.6.5 was released on July 12, 2018—over 4 years ago. There have been many fixes and improvements since then. If there’s an Extra that’s had fixes but its minimum compatible version is newer than 2.6.5 you may not have access to that latest version.

Thank you for your response. No errors so far, PHP Version is PHP Version 7.0.33.
The simple snippet: [[!Personalize?


Welcome back [[]]



You are not logged in



]] [/quote] is working appeared the information, when i uninstall the notify and stops to appeared when i install the notify. No any error in logs and this is very strange.

How in the heck are you still running PHP 7.0? That’s been unsupported for 3 years:

I don’t mean to harp on this but it’s only a matter of time before your site or server get’s owned.

Furthermore, it’s even possible it’s currently compromised.

Are you testing personalize while logged in as a Manager user? I also can’t figure out how Notify would impact this. I’d assume it’s just meant to send an email on an event. This will really need some good questions from @bobray to debug.

I tried both and while logged in as a manager user and not but the result is the same.
I will try to upgrade the system an php version and tried again

What is the actual code in this tag?

Definitely upgrade your PHP version to the latest 7.x version (I would avoid 8.0 for now. You should be able to upgrade PHP in cPanel if you have that.

The next thing you should do is to back up the site, then install UpgradeMODX and upgrade to MODX to 2.7.0, then 2.8.0, then 2.8.4. It’s important not to skip any x.x.0 versions in the process.

Like Jay, I can’t think of any way that Notify would interfere with Personalize. Once you’ve updated MODX to 2.8.4, check in Package Manager to see if any extra upgrades are available. While you’re there, make sure Personalize is installed.

the code is the default one:


&yesChunk=@CODE: <a href="[[~45]]" title=" " class="fas fa-user-circle text-success font-size-sm mr-3"></a> <a href="[[~41? &action=logout]]" title=" " class="fas fa-sign-out-alt text-success font-size-sm mr-3" title=" "> Logout</a>
&noChunk=@CODE: <a href="[[~42]]" title=" " class="fas fa-user-circle text-warning font-size-sm mr-3"> Login </a> <a href="[[~43]]" title="" class="fas fa-sign-in-alt text-warning font-size-sm ml-2"> Registration </a>
Any way i will follow your instructions to update modx and i will inform you about the result. Thank you


Actually i have difficulties with php update. I updated my local server that hosts the modx to php7.4 but modx still searched the old php version. Is there any modx configuration file i need to edit and change php path in order to modx to start using the new php version?

No. PHP runs MODX not the other way around.

then how to do it? I upgraded to PHP 7.4 (in ubuntu php -v gives exactly this version) then i removed 7.0 and 7.1. and then started apache and modx . In modx system info it gives php version 7.1. Then i renamed /etc/php/7.1 and the modx cannot start. So some how it looks for 7.1 and not the new installed version. Or i m doing something wrong ?

You probably have to change the apache configuration.

I don’t see anything wrong with that code, but you might try just putting it in a chunk and using the chunk name in the tag.

So all system is updated with the following versions: MODX Revolution 2.8.4-pl (traditional), PHP Version 7.4.32, personalize-3.7.2-pl, notify-1.5.3-pl, login-1.9.10-pl, subscribe-1.3.0-pl.
Before notify installation
I can perform the following without any problem:

  1. button Login exist
  2. I press button login insert user name and password it logins perfectly and insteed of the button login shows the logged user name and a button Logout.
  3. i press the logout button and it logged out successfully.
    After “notify” installation
  4. button Login exist
  5. press button login, insert user name and password it logins(because i see the user name in “Who’s Online” but the button is not change to logged username and does not appeared the logout button .
  6. In case i press again the button login it gives me a link with title logout: “https://…/?action=logout” without to logout.
    Login resourse: " [[!Login? &loginTpl=tpl_login &actionKey=action &loginKey=login &redirectToPrior=1 &logoutResourceId=1]] "

If i am restoring the notify’s installation using option restore: Restore(This will restore the prior version’s settings as they were before the newer version was installed.) everything returns to normal and works as it should be.

Thanks, that’s a very good description of your problem.

Do you need the Notify TV on the same page as the Personalize snippet tag? If not, a workaround would be to use a different template for the page and not connect the Notify TV to it.

Also, see if there’s still a problem if you don’t use @code.

I’ll try to find time to look into the code of the two extras.

It appears that you have &ph set to but your placeholder is (unless that’s a typo).

BTW, in posts here, please surround your code with three backticks above it and three more below it, not blockquote.

you are correct thanks for that i put &ph to
I tried without @code but the same result. I tried also to use the exact code from personalize documentation [[!Personalize? &yesChunk=`@CODE:<p>Welcome back [[]]</p>` &noChunk=`@CODE:<p>You are not logged in</p>` &ph=`` ]] without any success.
I think that for some reason after notify installation the noChunk - yesChunk does not react to scriptProperties different data(inside the snippet .
Also forgot to mention that on the first notify installation i got the error bellow:
Error 23000 executing statement: INSERT INTO `modx_property_set` (`name`, `category`, `description`) VALUES ('', 0, '') Array ( [0] => 23000 [1] => 1062 [2] => Duplicate entry '' for key 'name' )
Then i uninstalled notify truncate the table modx_property_se and install it again without any error.

I tried already to exclude notify tv from page i use the personalize but the result is the same.

Is it possible that you’ve somehow connected the NotifyProperties property set to the Personalize snippet?

If you’ve changed the actual placeholder name, try manually deleting all files in the core/cache/ directory.

I haven’t connected NotifyProperies with Personalize, but i do not know what is doing the script on Notify installation. Of course i deleted the cache manually.

Ok in order to test if some other module or extras creates the problem I made a completely clear new modx installation(+ new database) with following:

  1. MODX Revolution 2.8.4-pl (traditional)
  2. PHP Version 7.4.32
  3. login-1.9.10-pl
  4. personalize-3.7.2-pl
  5. subscribe-1.3.0-pl
  6. notify-1.5.3-pl
    No any css or js or other scripts or extras.

and unfortunately the problem is the same: