PDO tools error when upgrading to php 7.3 or 7.4

Hi All,

For 1 site I have, when I upgrade php to 7.3 or 7.4 I anm getting the following error ( site doesn’t load but the manager is fine )

pdofetch.class.php:152 Stack trace: 
#0 /home/customer/www/mysiteurl/public_html/core/cache/includes/elements/modsnippet/1.include.cache.php(36): pdoFetch->run() 
#1 /home/customer/www/mysiteurl/public_html/core/model/modx/modscript.class.php(76): include('/home/customer/...') 
#2 /home/customer/www/mysiteurl/public_html/core/model/modx/modparser.class.php(537): modScript->process(Array) 
#3 /home/customer/www/mysiteurl/public_html/core/model/modx/modparser.class.php(251): modParser->processTag(Array, true) 
#4 /home/customer/www/mysiteurl/public_html/core/model/modx/modresource.class.php(546): modParser->processElementTags('', '<!DOCTYPE html>...', true, false, '[[', ']]', Array, 9) 
#5 /home/customer/www/mysiteurl/public_html/core/model/modx/modresource.class.php(498): modRe in /home/customer/www/mysiteurl/public_html/core/components/pdotools/model/pdotools/pdofetch.class.php on line 152

It’s running the latest version and all extras are up to date, I have another 3 sites on that server all with the same addons and they are all fine.

I’ve deleted the cache etc via FTP

Anyone got any ideas or pointers ?

Thanks

This has been Solved

Could you please share what solved it in case someone else comes across this question in the future?
:slight_smile: