Packages go missing

Hi Folks

I think I’ve had this problem before some years back.
Unfortunately I think that particular thread now precedes the current forum years.
My issue is I add a zipped transport package to the core/packages folder,
however when I go to install via ‘Download Extras/Search locally for packages’,
I get ‘No data to display’.

I’ve wracked my tiny brain and looked far and wide and tried a few things without success.
On Bob Ray’s troubleshooting page the possibility of it being a cURL issue suggests itself.
Again, unfortunately, when pursuing that potential solution and searching through the ‘php.ini’ file for the line
it is simply not there.

Can anyone kindly shed any light here?

Many thanks

My Setup:
MODx 2.8.3
Mac High Sierra 10.13.6
PHP 7.4.9
MySql 5.7.30
Chrome 92.0.4515.159
Safari 13.1.2

1 Like

I don’t think cURL is used for this. As far as I can tell when you click ‘Download Extras/Search locally for packages’ the processor workspace/packages/scanlocal is executed that just loops the files in the core/packages folder.

Maybe this folder is not readable or your package file has a name that doesn’t match (must end in and contain a dash -).

1 Like

Hi halftrainedharry (love that btw)

I’d looked at the zipped/unzipped matching thing a couple of times and just couldn’t get it to work.
I also gleaned that it’s good practice to leave out underscores, hyphens etc.
However this still failed to remedy things.
But with your fresh suggestion ringing in my ears, I matched up the file names once again and lo this has worked (although the file name is full of underscores etc.)
I’m sure you know what it’s like when you can no longer see the wood for the trees…

Good shout indeed Sir.
Many thanks

1 Like

Can you clarify what you mean by matching up the names? It will give folks a clearer understanding of what solved your issue. Maybe a screenshot or listing where you changed the names?