Need help with mystery connector 500 error

I’m getting a 500 error on a calls to the resource/getnodes processor. All other processor calls are working fine. The result is that no resources show in the tree, otherwise, the Manager seems to be fine.

The site was upgraded from 2.8.3 to MODX 3 with UpgradeMODX.

Here’s the normal call to that processor:

Here’s what I’m seeing:

I can’t find where that URL is generated.

The site with the issue is in a subdomain and has a renamed connectors directory, but since all other connectors are working, I don’t think either of those are causing this.

Any clues appreciated.


I think these are both normal calls to the Resource/GetNodes processor.

  • action=Resource/GetNodes&id=root returns the contexts.
  • action=Resource/GetNodes&id=web_0&type=MODX\Revolution\modContext should return the root resources of the context “web”.

Any custom resource types on that site?

What does the server error log have to say about the 500 error?

There are Articles.

The only potentially relevant log error is: Cannot declare class modDriverSpecificProcessor, because the name is already in use referer:

As far as I can tell, that only appears in deprecated.php, so maybe that’s being included twice somehow.

I’m also seeing this in the server error log now:

Backend fatal error: PHP Fatal error: require_once(): Failed opening required 'core/model/modx/modprocessor.class.php' in core/components/articles/model/articles/articlescontainer.class.php on line 22.

This shows up loading any page in the Manager where the resource tree is displayed.

Articles will need to be updated for 3.0. Relevant issue:

It looks like there has been quite some activity to get it ready, but no release yet. Maybe @joshualuckers has some ideas on when we can expect that? :slight_smile:

Thanks for nudging me in the right direction. Commenting out the 3 “require_once” statements in the ArticlesContainer class got the resources back in the tree (though Articles still doesn’t work – glad to hear it’s not being abandoned).

Now that I can see the resources, two other problems are apparent. I can visit the home page, but friendly URLs aren’t working. Going to index.php?id=## does work. When refreshing the URIs didn’t work, I tried turning off FURLS, but got an access denied response when the System Settings tried to save, even though I’m a sudo user.

I can’t give a timeline since my time is limited and when I do have time it’s mostly spend on MODX itself.

However anyone can help and submit PRs!

This must be my week for rookie mistakes.

I originally had the name of the DB wrong in one line of

Then, the Articles bug bit me.

Finally, I had the wrong rewrite base in .htaccess. It’s surprising how much stuff works even when that’s wrong.

Thanks for all the help! It made a difference.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.