My old MODX installation show an empty page

My MODx 2.26 web app does not work and show an empty page

Good day
I built a web app some year ago but no update has been perform and the owner called because, it’s web site is showing a white page.

I was thinking that my index.php page has been hack and I replaced it but nothing happen. As it an old MODx web site, I wunder if the PHP is not compatible.

When I go to manager, I got this error

Fatal error : Call to a member function get() on a non-object in /home/www/bff53dea2cc171caecad1b7c3907f0f4/web/core/model/modx/modmanagerresponse.class.php on line 41

Do you have any idea, if ther web site has been pirated or if it a version solution that I could solved quickly?


Hi @pierrot1010 and welcome to the MODX Community.

There are all sorts of reasons your site could not be working including a hack but the first, I’d check is whether or not your host upgraded the PHP or MySQL software recently. 2.2.6 will not be likely compatible with PHP 5.6+ and I know for a fact it’s not compatible under certain conditions with PHP 7.

Another possiblitly is that your db credentials changed or for some reason you cannot connect to the database properly. This was the case in this thread in the old Forums.

I’d be seriously surprised if a site running 2.2.6 was not compromised in some regard. The compromises of sites last July was widespread and very serious—even when sites remained online and didn’t show any outward symptoms.

I should start by re-running the setup, check the core config and the database.

Thank a lot,

Some one can explain me why my contain the following line

 $database_type = 'mysql';
$database_server = '5x.3x.1xx.11x';
$database_user = 'port';
$database_password = 'port111';
$database_connection_charset = 'latin1';
$dbase = 'port';

I do not what is that IP address (I replaced some numbers with x).
I NEVER choose a username and password as we can see!!
The IP adresse show an Apache server default page!

Your site was compromised because the /setup/ directory was still in place. Basically, an attacker installed a new site in its place.

There’s been a lot of that going around, hence the warning posted last week.

Hello. Thank for your reply
I run /setup

Does the install will earise the ressource? or should I upgrade
There is another option: Advanced Upgrade Install. Does it Upgrade or install.

My idea now is to reinstall my modx with the same version but selecting a new and empty database. Then modify the to link it to the previous database. Both database have the same username and password and hosted at the same place.
In thta way, I am sure thta the dabase will not be affected.
The probleme is the addon I installed, but I gess I could reinstall it later

I alsmost solve my problem, but I make a big mistake. I upgrade the package and I forgete to remove captcha. I changed the password and log off.

Now I can not log any more because it ask me the captcha calcul and it does not show the image.

How can I totaly remove captcha manually???

I deleted

I unactive captacha from the database (table : modx_transport_packages )

But alway show me the calculate field and when I try to login I got that error

$_SESSION Variable not set

Hope you can help me soon. Thank a lot

Hi @pierrot1010, to disable the captcha plugin, login to the database using a tool like phpMyAdmin and set the disabled column for that plugin in the modx_site_plugins row to 1. This assumes your database prefix is modx_.