Modx3 Error after installation

Receiving the following error using the Package Manager.

“Modx received a blank response from the provider. Please double check your service URL and make sure the provider is a valid provider”

Check the provider: Provider (default)

We have Modx3 installed on a Windows 2019 Server Dev machine and thought that perhaps this was the issue. However we spun it up on a Ubuntu 20.04 dev server and got the same error.

We’ve checked permissions on both boxes (they were okay). We then basically gave unlimited (removed all restrictions) and permission for everyone just to make sure it wasn’t a perms issue.

Re-installed and the same error.

We currently have several 2.84 and 2.86 servers in production with out issue. At this point, we are stumped. Really want to keep current so this is a bit of a concern.

Our conclusion is that it is NOT an OS issue, so either we are missing something or their is an underlying problem with V3.

We suspect it has something to do with ssl as I we think V3 uses https as apposed to http???

We’ve googled the heck out of this and checked every response and made sure we have all the prerequisites and both servers are fully up to date.

In case of questions, the reason for the Windows Servers (as well s “ix” boxes) is that we provide hosting for both environments to meet customer requirements.

Any guidance or thought are appreciated.


It’s likely to be a problem with the SSL certificate.
Maybe take a look at this post:

Is your typo? If not, that would explain the problem. It should be

Opos, Typo…

Good catch.