MODX 3.0.3 - resource creation gone crazy

Site up and running, more than 1500 resources, everything working fine, normal, it’s modx.

Since this afternoon, without any manipulation of parameters or other actions that could affect operation, it has become impossible to create documents in the manager:

Using the plus button at the top, or right-clicking on a folder, the popup opens, you enter the title and template in the popup, but when you save, nothing happens, the popup never closes, the resource is not created. Regardless of the title and template chosen.
The problem is the same in Collections: it’s impossible to create new documents in collections!

There’s no error log in the manager,

just a console log returned by connectors/index.php :
Object { f: {…}, a: {…} }

in the first object, there’s an error field and I see this :
result: errors: Array(1)
id: “alias”
msg: “This field is required.”

Alias is required??? but since when? There isn’t even an alias field in the resource creation popup.

To check, I disabled friendly_urls, and now everything works!

I’ve been using modx for a long time, and this is my first time with this problem.

  • there are no file loading errors,
  • nothing in the console
  • I’ve tried several browsers
  • I’ve cleared the caches, as well as the cache folder on the server

I’ve been working on this site for over a month, with friendly_urls enabled, and everything was working fine until today.
I’ve never seen this before, and I don’t understand what I could have done to cause this problem.
The site is under construction, so I can obviously continue to work without friendly_urls, but when it goes online, my client will want them.

Has anyone had this problem before?

Why does MODX no longer want to create resources, claiming that the alias is missing, when it’s not possible to enter it in the resource creation popup?

90% of the work is done and then, bang! The problem that kills. Why are you doing this to me, MODX, that I’m so fond of?

Is the system setting automatic_alias set to “Yes”?

Reminds me of this issue, but this should be fixed by now:


no, automatic_alias is set to no…
and that’s it, turn it to yes solve the problem !

Thank you again halftrainedharry,
not the first time you save me.