Modx 2.8.* upgrade problem

hi modexers. we installed the “UpgradeMODX” plugin so as to upgrade from modx2.8.4 to 2.8.5 - on php8.1 and mysql 8.0.32 . As soon as i click on the “upgrade” button for 2.8.5 in modx/manager a small white popup box appears:

Error requesting page /assets/components/upgrademodx/connector.php?action=downloadfiles&

any ideas?

we then copied all the files over from “modx-2.8.5-pl” and go to “” and that does not display any modx upgrade screen - it just displays our default homepage. i tried a few cache/cookie cleared browsers and nothing. no idea why neither of those are working.

WE ROLLED BACK THE CODE and did the steps as per Upgrading MODX - Maintenance | MODX Documentation and that gave us a proper folder and the install went fine then :slight_smile:

1 Like

Did you use UpgradeMODX for the final upgrade?

hi Bob. we didn’t use the plugin. we rolled back to our working modx2.8.4 code. we checked if any plugins needed an upgrade. we killed the sessions, logged out of /manager and deleted /core/cache. then the upgrade folder for modx.2.8.5 was copied across and it replaced the current modx2.8.4 code files. then the “” screen was visible and working and the upgrade to 2.8.5 was straightforward with no visible errors. we logged in and we see “modx 2.8.5” in the required places so we presume it was successful :slight_smile: . how would we know if it worked? we see no errors in error_log or in .

I just updated my localhost install from 2.8.4 to 2.8.5 with UGM with no errors.
I tried removing all versions of UGM and verified that the connector.php file was gone (along with all other UFM files).

Then I installed UGM 2.3.3 alone, and the connector.php file was there. I upgraded to 2.8.5 again with no errors. I don’t know what caused your connector.php file to be missing. Possibly a download error in Package Manager when you installed UGM, but I suspect it’s a pretty rare event.

that wasn’t the fix for it. i went to another modx2.8.4 site and installed the “upgrademodx” plugin and ran it and the same white popup message appears - and i checked this time, and the connector.php file is there so the error message is not referring to a missing file - it is the execution of that file

i can upgrade them using the raw “modx-2.8.5-pl” code file and copying across the files to write over the modx2.8.4 files - that worked fine already. what do you look for Bob when you do an upgrade to make sure it installed correct? if you see the correct version in the top right hand corner of the /manager e.g. “MODX Revolution 2.8.5-pl” and also in the “system info” tab in /manager e.g. “MODX version: MODX Revolution 2.8.5-pl (traditional)” ? once you see both of those, the upgrade is likely fine?

I think I get it now. %2F is an encoded directory separator, and I suspect that your Apache server has AllowEncodedSlashes off.

The only URL encoding I can find in UGM takes place inside Guzzle. I don’t know if there’s a way to control it.

I’ve had no luck figuring out where those slashes are being encoded to %2F. I’ve discovered that the correct setting for AllowEncodedSlashes would NoDecode (which only turns off encoding of slashes) rather than Off which is less secure.

I was able to upgrade 2.8.4 to 2.8.5 on MODX Cloud using UGM with no trouble.

I also upgraded Bob’s Guides using UGM with no errors. I can confirm that in none of these cases were the slashes encoded. Possibly you have an SEO-related plugin that’s encoding the slashes. It’s clear that UGM is not doing that.

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.