MODX Community

MIGX access to media source

I am unable to access an image field from a MIGX template variable when logged in as a non-admin user. The template variable is mapped to a /site-images media source. The test user has full access to all other fields within it, all of which are field type text or URL.

I have created other, non-MIGX image TVs that the non-admin user can use.

The sequence for the MigX TV was:

  1. Created and tested the MIGX template variable as admin user
  2. Created the /site-images media source
  3. Created the non-admin user and user group
  4. Tested the MIGX template variable as non-admin user and discovered the issue
  5. Creating a new image template variable, assigned to /site-images media source, successfully tested and used as both admin and non-admin user
  6. Created new MIGX template variable that duplicates the original’s XML, associated to /site-image media source
  7. Tested successfully as admin user. Encountered same test user access issue to image field.

The test user can access and use the /site-images media source.

As best as I can tell from the above, this is related to MIGX. I would really appreciate any ideas about what to try next.

A further note to this issue – I created a new migx tv that includes only an image field, and associated it to the /site-images media source.

I cannot access the media source from the resource page either as an admin or non-admin user.

@bruno17 would you mind weighing in on what I’ve experienced as described above?

Mate is the image path wrong or it’s not being displayed at all?

I had a similar problem with the Migx paths for custom media sources, hope that helps:

https://forums.modx.com/thread/101641/nested-migx-image-path-custom-media-source

Cheers!

In my case, my non-admin user cannot even access the media upload in the manager.

The admin user can, and images applied by the admin to the midx tv render in the front end, so it’s not a path issue in that regard.

Mate that sound like a permissions problem.
Have you been in Settings (gear icon)/Access control list/

Under User Groups, right click to (anonymous), click on Update User Group
and add permission under the TAB permissions/ Resource Group Access.

Hope that is clear, cheers!

I agree, it does. I’ve been all through the ACL settings. I don’t think it’s access, though, because the non-admin user can use regular image TVs that are assigned to the /site-images media source with no issue. It is only this MigX TV that has caused a problem, hence that’s where the issue seems to lie.