Media browser does not display images if standard media source is hidden

Hi there,

I recently met one of the harder end bosses in Modx: the ACLs. And I need a walkthrough. :sob:


I created a separate media source to hide any voodoo files from a client so he cannot delete any important data. The media source “images” is available for the user group “content editor”, the media source “filesytem” is available to administrators only.

The subfolders and files are shown in the file tree, and the user can work with the files. When the media browser is used, no file is shown. Only when media source “filesystem” is switched on again, the files are shown. The problem seems to occur only when using a TV. If I try to add or change an image in the content text area, media source “images” is shown without any problems.

Step to reproduce

  1. Create a media source “images”.
  2. Set user group editors (uses “content editor”), set minimum rights “member”, and set ACL “media source admin”. Set basePath and baseURL to “images/”.
  3. Limit access to media source “filesystem” to admins only (admins, member, media source admin).

Observed behavior

Works great: media source in the file tree.


Works great: media source in the media browser when accessed from the text area “content”.


Doesn’t work: media source in the media browser when accessed from any of the image TVs I use. Please note that the media browser now also shows “(web)” in the header.

What did I miss?


ModX version: 2.8.4.

Try setting the default_media_source system setting to the media source that should be used by the TVs, so in this case Bilder.

Thanks for you reply.

I already changed the setting but it didn’t have any effect on the TV. Any other idea? :upside_down_face:

Is this a regular image TV? Then there should also be a tab “Media Sources” when editing the TV, where you can select which media source should be used.

Solution for future me and other desperate people in need:

Tab “Elements” > Section “Template Variables” > TV in question > Tab “Media Sources”.

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.