Manager Not Logging In

I recently launched a website on MODX 2.8.6. After updating the DNS to point to the new server, the MODX Manager will not login. When I enter the credentials and then hit ‘Login’, the page refreshes with the login screen and empty username and password fields.

When I tried using the password reset feature, I received the password reset email. But upon clicking on the reset link, the same issue occurs.

I tried going through the install widget to see if that would clear things up but no luck. I also emptied the session table as well, but that also didn’t work.

I didn’t experience this when I was working on the development of the site. It only happened after we pointed the client domain to the new site.

MODX 2.8.6

Have you checked over the paths in your config files after the move?


Thanks dejaya, I have checked those and they appear to be correct.

This is usually a sign that something with the session doesn’t work correctly.
Do you get a cookie back after trying to log in?
Does anything get added to core/cache/logs/error.log when you try to log in?

Thanks @halftrainedharry No, I don’t see the error.log file in that cache folder.

It also seems that when I try to login, no cookie is being created in my browser.

Solved. The system setting session_cookie_domain was set to YES. Removing this resolved the issue.

1 Like

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.