Manager Form Customisation

Hello, since a few days and without me understanding the cause, the personalization of the forms in the manager does not work anymore. The pages are displayed normally, without taking into account the personalization settings (which worked fine a few days ago…) and the console displays a javascript error which would seem to be due to ExtJS :

Uncaught TypeError: can't access property "id", newTab is undefined

the problem affects all page templates that should normally be customized.
Does anyone have any idea what might be causing this problem?

(modx 3.0.3)

Can you figure out what exact setting causes this error? And maybe provide some steps how it can be reproduced on another system?

Unfortunately these Ext.js error messages are often not very useful.

There were other problems in MODX 3 concerning “Tabs” that have been fixed. But as you are using the current MODX version, this is probably a new issue.

Thank you for your answer, but No, it drives me crazy.
I’ve been using modx for a long time, as well as form customization.
I have never been faced with this problem before.

i deleted all customisation, then recreate… and the problem is still there.

the site is 90% finished, everything worked very well.

After working on the front end for some time, I realized this problem in the manager.
And I’m afraid I’ll have to reinstall and redo everything just because of this problem…

So can you share what form customization you do exactly?

The issue that you’re experiencing has been fixed with PRs #16364 and #16360, but those changes await the next patch release (3.0.4) which will hopefully be very soon. While you could apply those patches manually, you’d also need to either rebuild the compressed js file manually (if you know how to) or temporarily change your compress_js system setting to “No” to see the changes take effect.

I’m curious to know why @_lol 's Form Customisation has been affected by this bug but not others. I have plenty of sites on 3.0.3 and Form Customisation seems to work fine.

It’s hard to say without seeing their specific setup, but the fixes I mention should prevent the error referenced in the initial post; I know because those fixes were submitted by me :wink:

1 Like

Really, on all the sites I’ve done, I’ve done this kind of settings dozens of times, always without problem.
In my example, I just want to display the TVs on the main tab
this short video show the manager before the problem (old server, php 7.4)
and then now. (new server PHP 8.2)

you can see on the form customization page that the name of the template is not displayed correctly even though it seems to be correctly selected. I don’t know if this has anything to do with it…

what can go wrong?

@smg6511v2 : i’m not sure it’s related because 2 days ago, the same site, with the same settings worked fine, and i didn’t notice when the problem occured first.
(And I am unable to rebuild modx manually… )

thank you for your help.

I can reproduce the error message when I try to hide the region modx-resource-access-permissions in the form customization.

This pull request seems to fix the problem:

But as @smg6511v2 wrote earlier, you have to change the compress_js system setting to “No” when you manually patch the file.

This happens on all my MOD3 sites occasionally. Refreshing the page usually brings the Template names back - so I don’t think that’s related.

Out of interest - have you tried setting your TVs to any other regions other than modx-resource-settings?

For example, modx-content-above

i can confirm that :

  • creating a new tab and put TVs on it works fine
  • put the same TVs on modx-resource-settings failed
  • hide any region failed (tabs not hidden and all TVs back to TV tab…)
    very strange behavior…

I tried to modify manager/assets/modext/core/modx.js (and disable js compression.)
but the problem is still here.

so i think i will have to wait for the 3.0.4 release. any date expectted ?

That fixes another small issue, but it’s the changes in the two PRs I mention above that will fix your issue. There’s no date for 3.0.4 yet, but I’m encouraging the core team to move toward that release sooner than later.

1 Like

Same issue here. Presented as tabs not loading for a collection resource, and the JS error “newTab is undefined”

Took me forever to find this particular thread.

I can’t, for the life of me, understand why this has been fixed in modx 3.0.4-dev for over 8 months and there’s been no release to ensure a simple upgrade fixes it without having to install a dev release. Reminds me of dealing with magento devs :frowning: