Mail wont send - PHPmail & SMTP - Formit

Out of nowhere my contact forms stopped working.

I have no clue why.

My go-to tool is QuickMail. And it’s clear something is not working:

And with SMTP:

I’ve double checked the SMTP details and they are working.

Does anybody has a startingpoint?


Hi, it actually looks good:

Your error says “failed to connect to server”:

  • Have you tried with the port 465?
  • Have you tried with the prefix tls?
1 Like

Are you using a Google account to send with SMTP? If the Google account requires two-factor authentication, they now require you to get an APP token to send through SMTP.

1 Like

Thanks @sebastian-marinescu.

Yes I’ve tried different port and TLS, no luck there.

Starting to think something is wrong with the host.

No this is the smtp straight from the hosting provider.

Strange thing is, a day before it was working perfectly fine with phpmail. It has been working for a year or 2.


I’ve connected MailJet to a client’s site and there was something weird going on as well. I tried multiple hostnames, SSL/TLS (or off), nothing seemed to work.

Then all of the sudden, I tried the initial config I was using and it worked just fine. It has been working for a few months now, so it seems fine.

1 Like

Tried all but none work. It’s a modx error because the mailfunction on the server does work.

Anyone else have an idea? The hosting has no clue… me neither