MODX Community

Index.php?id= is not converting to SEO friendly URL

Hello,

currently I’m editing a website, which is online for more than 2 years without any updates or something like this. So I’ve updated to 2.7.3 and fixed several problems, one of them was the missing of SEO friendly URLs. So the SEO friendly URLs are working great for each site and there are no problems until now - expect of this one:

All sites are still available with there old URL (index.php?id=XX) ! That’s a big problem, because Google already know them and now there’s a duplicate content for each site.

It’s EXACTLY the same problem which was already a topic in the old forum:
https://forums.modx.com/thread/?thread=100007&page=1

Has anyone an idea why the hell this happens? I’ve cleared the cache via the manager and manually several times, I’ve also tried to add the following code to the htaccess, nothing works, there is no redirect:

RewriteRule index.php?id=2 https://www.DOMAIN.de/kontakt [R=301,L]

Already installed SEO Tabs and included all sites, but it doesn’t seem to change anything.

All of my sites work this way. I thought it was normal behavior. You might be able to change it with some rewrite rules but I’m not sure.

However, you can fix your issue with Google by using canonical tags in your metadata.

Like I’ve written, I already tried it with RewriteRule, but it doesn’t gave me the newer URL.

Canonicals are in use for every site, but I doubt it would be a problem because Google already know the sites.