MODX Community

ImportX problem

I’m trying to use importX to import a bunch of resources from a csv file.
the CSV is formatted correctly, but I’m getting this error:

Running pre-import tests on submitted data...
No errors in pre-import found. Preparing import values...
No errors found while checking the import values: 37 items found. Running import...
0 of 37 resources were imported successfully
Error: An unexpected error occurred saving the resource. Resource not specified.

I’ve tried pasting the values into the import window, and I’ve tried uplaading a CSV - bt I get the same error.

The CSV file looks like this:
pagetitle|tv15|content|parent|tv7|tv3|tv5
Vintage Leather Jacket||<ul><li>Genuine leather</li><li>Brand on label &lsquo;top skins&rsquo;</li><li>Fits size S</li><li>Good condition (normal wear and tear around the buttons)</li></ul>|44|cc51.jpeg|499|1

Has anyone come across this error before?

Thanks
Andy

Hoi,

Have you looked at the list seperator while importing ? I use ; for a seperator, but since you use &lsqou; it could be a problem.
Which csv save do you use from excell or other program ?
That could be an isseu, use the one with listseperator.

Appeltje

Thanks. No I used pipe ‘|’ guy or my separator.
Funnily enough when I cleared the cache, the issue disappeared!