I don't know exactly when the problem occurs, but it always happens when I want to save a chunk. Then the site crashes :(

I get this error message. If I empty the cache, it still remains, only if I fill it with my backup from the old cache, then it works. After trying to save again, the same error message appears again:

Fatal error : Uncaught Error: Call to a member function makePlaceholders() on null in /homepages/5/d822938938/htdocs/modx/core/components/minishop2/model/minishop2/minishop2.class.php:87 Stack trace: #0 /homepages/5/d822938938/htdocs/modx/core/cache/includes/elements/modsnippet/62.include.cache.php(6): miniShop2->initialize(‘web’) #1 /homepages/5/d822938938/htdocs/modx/core/model/modx/modscript.class.php(76): include(’/homepages/5/d8…’) #2 /homepages/5/d822938938/htdocs/modx/core/model/modx/modparser.class.php(537): modScript->process(NULL) #3 /homepages/5/d822938938/htdocs/modx/core/components/pdotools/model/pdotools/pdoparser.class.php(273): modParser->processTag(Array, false) #4 /homepages/5/d822938938/htdocs/modx/core/model/modx/modparser.class.php(251): pdoParser->processTag(Array, false) #5 /homepages/5/d822938938/htdocs/modx/core/components/pdotools/model/pdotools/pdoparser.class.php(64): modParser->processElementTags(’[[$Produktlink]…’, ‘[[msProducts?\n …’, false, false, ‘[[’, ‘]]’, Array, 9) #6 /homepages/5/ in /homepages/5/d822938938/htdocs/modx/core/components/minishop2/model/minishop2/minishop2.class.php on line 87

Maybe check if the extra pdoTools is installed correctly or try to reinstall it.

Hey @halftrainedharry :smiley:
I somehow can’t uninstall the tool :confused:
do you know where I can see this on my SFTP access?

Maybe check if the files core/components/pdotools/model/pdotools/pdotools.class.php and core/components/pdotools/model/pdotools/pdofetch.class.php exist.

Are there errors in the MODX error log core/cache/logs/error.log with a message like “Problem getting service …”?

Hey Harry,
Thanks very much
in the error report I only get Problem getting service miniShop2, instance of class miniShop2, from path

@halftrainedharry
So, I have now reinstalled PDOTools. Now comes the same error:

Fatal error: Uncaught Error: Call to a member function addTime() on null in /homepages/5/d822938938/htdocs/modx/core/cache/includes/elements/modsnippet/11.include.cache.php:137 Stack trace: #0 /homepages/5/d822938938/htdocs/modx/core/model/modx/modscript.class.php(76): include() #1 /homepages/5/d822938938/htdocs/modx/core/model/modx/modparser.class.php(537): modScript->process(NULL) #2 /homepages/5/d822938938/htdocs/modx/core/components/pdotools/model/pdotools/pdoparser.class.php(273): modParser->processTag(Array, false) #3 /homepages/5/d822938938/htdocs/modx/core/model/modx/modparser.class.php(251): pdoParser->processTag(Array, false) #4 /homepages/5/d822938938/htdocs/modx/core/components/pdotools/model/pdotools/pdoparser.class.php(64): modParser->processElementTags(’[]’, ‘[[$head? &extra…’, false, false, ‘[[’, ‘]]’, Array, 9) #5 /homepages/5/d822938938/htdocs/modx/core/model/modx/modtemplate.class.php(126): pdoParser->processElementTags(’[]’, ‘[[$head? &extra…’, false, false, ‘[[’, ‘]]’, Array, 10) #6 /homepages in /homepages/5/d822938938/htdocs/modx/core/cache/includes/elements/modsnippet/11.include.cache.php on line 137

What snippet is your snippet with the ID = 11?

Somewhere around line 137 in this snippet there is a call to addTime(). On what object is this function called?

The snippet with ID 11 is pdoMenu.
on line 137 is is the call

$pdoMenu->pdoTools->addTime('pdoTools loaded');

Can you check that the plugin with the name = “pdoTools” exists, that it is active and runs on the event OnMODXInit?

Are there message "Could not load class: … " in the MODX error log?

And in the error log it says here (ERROR @ /homepages/5/d822938938/htdocs/modx/core/xpdo/xpdo.class.php : 644) Could not load class: modC from mysql.modc. several times

And underneath it says repeatedly:
(ERROR @ /homepages/5/d822938938/htdocs/modx/core/xpdo/xpdo.class.php : 762) modC::load() is not a valid static method.

I think these modC errors are unrelated.
Seems to be a bug when dragging categories around


The real problem seems to be that pdoFetch can’t be loaded. (But there are no error messages to corroborate this.)

Maybe you can check the values of the system settings pdofetch_class_path and pdotools_class_path, pdoFetch.class and pdoTools.class.

Do you know what default FQN pdoFetch has? The value for me is pdotools.mmlfetch. I don’t think that’s right

pdoFetch.class = pdotools.pdofetch
pdoTools.class = pdotools.pdotools

Oh… That was the problem…

Thank you so much :slight_smile:

This topic was automatically closed 2 days after discussion ended and a solution was marked. New replies are no longer allowed. You can open a new topic by clicking the link icon below the original post or solution and selecting “+ New Topic”.