I can't update plugins MIGX, SimpleSearch - I get the same error. I tried it on several of my sites

MODX 3.0.1-pl, 3.0.3-pl

So what is the actual error message in the console?
It looks like there is some problem with unpacking the ZIP-file (but most of the message is covered by the “Error” pop-up).

Maybe take a look at the ZIP package file (in the folder core/packages) and make sure that the downloaded file is a valid ZIP file. Maybe the file got corrupted during the download.

This errors in " Error Log"
[2023-12-12 15:39:45] (ERROR @ /home/-------/www/core/vendor/xpdo/xpdo/src/xPDO/Compression/xPDOZip.php : 54) xPDOZip: Error opening archive at /home/----------/www/core/packages/simplesearch-3.0.0-pl.transport.zip
[2023-12-12 15:39:45] (ERROR @ /home/-------/www/core/vendor/xpdo/xpdo/src/xPDO/Compression/xPDOZip.php : 152) PHP warning: ZipArchive::extractTo(): Invalid or uninitialized Zip object
[2023-12-12 15:39:45] (ERROR @ /home/---------/www/core/vendor/xpdo/xpdo/src/xPDO/Compression/xPDOZip.php : 164) PHP warning: ZipArchive::close(): Invalid or uninitialized Zip object
[2023-12-12 15:39:45] (ERROR @ /home/--------/www/core/vendor/xpdo/xpdo/src/xPDO/Transport/xPDOTransport.php : 682) Could not unpack package /home/----------/www/core/packages/simplesearch-3.0.0-pl.transport.zip to /home/--------/www/core/packages/. SIG: simplesearch-3.0.0-pl

On the next attempt, SimpleSearch updated. But MIGX still gives the error.

reports that it cannot unpack the .zip archive /core/packages/migx-3.0.2-beta1.transport.zip to /core/packages/
tried to unpack the .zip file manually and encountered an error:
End-of-central-directory signature not found…

The most likely explanation is that the archive is broken. When I try to check the archive using the zip utility, I get the following error:
zip warning: Missing end (EOCDR) signature - either this archive is not readable or the end is damaged

because the error is reproduced on different sites, it is unlikely that the archive was broken accidentally once during downloading. Most likely the original archive in the repository is broken.

Please tell me what should I do, where am I wrong?

Try downloading the ZIP-file manually from here: MIGX 3.0.2-beta1 | MODX Extras
Then replace the corrupted ZIP-file in core/packages/ with this one (if the download is uncorrupted).

1 Like

This works. Why this problem occurs, what do you think?

I have no idea.
It could be a problem with the https://rest.modx.com/extras/ API.
But since I couldn’t reproduce the issue, it’s more likely an issue with your server/hosting.

1 Like