How Do I Increase the Speed of the Manager

I have reseller hosting with WHM, and 100GB of space. Just installed latest MODx… and finding the manager to be painfully slow. Each time a save or update is made, the tree recycles… and all folders close up again. How do I speed up the manager. I’m thinking this is something I should be able to do in the cPanel for my account. I realize that not every site can have the full monty. But today… I need the admin to be extremely responsive. Any feedback greatly appreciated.

I’d be tempted to bring this up with your hosting partner.

I run numerous MODX 3.x sites on a WHM / CPANEL reseller setup and everything runs smoothly and quickly.

Of course, these environments can vary greatly - but there’s no reason you shouldn’t be able to run MODX in a setup like this.

Your hosts should be able to monitor resource usage and identify any issues.

Thanks for the input. The host support is working on it, and just responded that they are still looking into it. In the past, I had one site that I really needed a faster manager, and they made it happen… stating that they could not do it to all of the sites. However, not sure what they changed, or whether it’s something that I am allowed to modify in my WHM.

1 Like

MODX is pretty heavy on ajax requests which means the server has lots of short requests in rapid succession. Latency to the server and any sort of processing delay can add up.

Recent versions of PHP (each jump from 7.4, 8.0, 8.1) have been known to be much faster, MODX 3 is also a little faster.

Tuning servers is not my expertise either but you can monitor a few things. If load is constantly high, you’re CPU bound and adding extras cores or upgrading the server will help. If memory is high, add more of that. If you’re not using SSDs yet, upgrade that.

1 Like

Hi Mark: Thank you for your feedback. I’m pretty sure that years ago when Patrick was still there, a switch to SSD was made. Support just got back to me stating: It looks like your PHP memory in your cPanel was only set to 32M. I have set this to 1024M. Please try this and see if this makes a difference for you.
Bummer though… I am not noticing any difference in speed. There is still a very delayed kind of process. I click on a tab… the safari progress bar rolls out… then the screen changes… then the tree refreshes… and is typically in an folders closed state. There is no way for me to upload any number of images without it taking a significant amount of time. All uploads have to be through cPanel. Yet editing, creating chunks, variables, etc. is still going to be a pickle. Something is wrong. My internet speed is 933+MB down and 41 MB up at the moment, so internet speed shouldn’t be the issue then, correct?

SkyToaster? They did offer both HDD and SSD as far as I know, so that’s worth double checking if you’re not sure.

I still use them for a few things, though support has definitely gone downhill now that I can’t just pester Patrick via Skype for every little thing :stuck_out_tongue: I’ve found it sometimes takes breaking through their 1st layer of support to get to the people that actually know what’s up.

It sounds like they changed the memory_limit php.ini value which isn’t a bad idea to increase from 32M, but I’d usually just have that at 128M or 256M as that’s more than enough for typical usage.

Unlikely that would be affecting speed, though, as it doesn’t mean your slice of the server has more memory all of a sudden: just that each process can use more memory before erroring out. If it was erroring out, though, you’d be getting errors and not just slow responses.

Unlikely, though there can still be latency. If you’re in the UK but your server is on the US West Coast then that will be slower compared to having it locally in the UK.

Do you use SiteDash? If so, enable extended monitoring for the site (that’s free for the first 3 sites) so it’ll start tracking CPU load and memory over time for you. I don’t think SkyToaster’s setup of cPanel/WHM will monitor that information, but like I said before if load is constantly high the server may just be too crowded.

Patrick did switch me soon after I started service there.

In terms of memory… the setting is 1024M,32M. Not sure if that is correct or not. I expected it to only read “1024M”… so perhaps there is an error with the change?

When I did the softaculous install, I could only use HTTP as the protocol. After install, htaccesss modification for autoSSL… the site is secure, but the manager was using HTTP, and thus safari continually showing alert that site is unsecure. I logged out and logged back in using HTTPS, and now the manager seems faster. Not sure how I can revert and make it permanent that I can only log in to the manager using HTTPS though. Tried searching “protocol”, https, etc, in the system setting but cannot find any reference.

You should be able to force HTTPS by uncommenting the following in the .htaccess file in your website root:

# Force rewrite to https for every host
#RewriteCond %{HTTPS} !=on [OR]
#RewriteCond %{SERVER_PORT} !^443
#RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Actually… I had not even paid attention… I always insert code specific to the domain. I will try to do that though. I think what is occurring is that I can log in to the manager via HTTP… that part is not converting. When I intentionally enter HTTS for the manager though… the interface is much faster now that the memory has been increased. Thank you for alerting me to this feature in the htaccess.