Community

Hi, Quip extra does not list comments in the backend!

Hi, I have implemented Quip extra for the comment forms and display functionality. It works just fine on the frontend side but when it comes to backend, strangely it does not list out anything @ Extras -> Quip screen … instead it shows following result in Latest comments section.

Also, there is nothingin Unapprooved Comments and Threads section.

Below is my code for Quip …

[[Quip? &thread=`myThread` &threading=`1`]]
[[!QuipReply? &thread=`myThread` &moderate=`1`]]

Thanks,
Ronak

what do you get in your browser-console in the network-tab when refreshing the grid?
Anything related in the error-logs?

Nothing, everything is clear in the nework tab. Each request with 200 ok status. In console tab I get error of ext-all.js as follows …

Uncaught TypeError: Cannot read property 'stopEditing' of undefined

I am currently using MODX version 2.6.5-pl … and the Quip downloaded from the Modx installer … Do not get idea as why it is happening … there is everything fine on the front side … comments are listed … I get comments count and etc.

Hi, I am now using Quip to post comments …

[[Quip? &thread=`myThread` &threading=`1`]]
[[!QuipReply? &thread=`myThread`]]

Also tried …

[[Quip? &thread=`[[+id]]` &threading=`0`]]
[[!QuipReply? &thread=`[[+id]]`]]

Both displays comment form and allows to post comment but in the Quip backend under “Latest Comments”, it just shows “Permission Denied” and does not list any of the comment I posted … I tried to post comments through admin login and without admin login but still no comments there in the backend to even review.

Can anyone tell what I am messing or missing here ?

Thanks,
Ronak

I assume you’re using Quip by itself and not in combination with something like Articles? Because I’m using Quip with Articles which gives a lot of options via its own interface, so there might be things to set there (if you are using it).

Other than that, Permission denied sounds more like a general permission issue, do you have sudo access and no special user groups, etc. setup?

Yeah !!! It was resolved …

Flush permission from Manage->Flush Your Permissions was the hack.

I am using MODX 2.6.5-pl and Quip 2.3.3-pl. This thread @ https://forums.modx.com/thread/?thread=38106&page=1 was very insightful but may be its for older MODX and Quip combination than what I am using.