Got error after installing the Modx

I reinstalled multiple times but still it shows same error

Did you check the file permissions of these CSS and JS files (and the folders they are in)?

yes, I changed the entire “manager” directory permission.
Now it looks like this:
Do I need to change other files’ permission manually?
If so, which files?

Won’t it be a security issue?
Because if I change the file permission those can be accessible by public users.


I have changed the “manager” directory permission but files are not getting/loading from the “mananger” directory

Did you only change the permissions of this one folder or also for the subfolders and the files in it.
The response code (403 Forbidden) implies that you still don’t have the permission to read these files.

I have changed all the files and folder permissions.
Now it’s working.

Still, I am facing problems when I install any “Extra/Plugin” it requires giving permission again.
Isn’t there any solution instead of giving permission to each “Extra/Plugin” after installation?

I’m not sure if that can be fixed in MODX. Maybe you have to change the default permissions that are used somewhere on the server.

During the installation of MODX, you can set the values for “New folder permissions” and “New file permissions”. This probably creates the system settings new_file_permissions and new_folder_permissions. But I don’t know exactly when these settings are used and if they are also used during the installation of new extras.

In each step, I am facing a problem.
Can anyone tell me, why is this error showing, and how to fix?

Article Container:

The “Could not find snippet” errors are probably from a snippet tag [[somesnippet]] somewhere in the content where no corresponding snippet with the name “somesnippet” exists.

For all the other errors in the error log: It would be helpful to have the whole error message and not just a screenshot that cuts off all the information.

For the error message in the grid: Open the developer tools in the browser and go to the “Network” tab. Then click the “Refresh” button (↻) under the grid. A new AJAX-request should appear. What is the response of this request? What value has the HTML response status code (400, 500)? Does something get added to the MODX error log when you click “Refresh”?

Are you talking about this?

Could be. It’s hard to tell from this screenshot.

Click on the request in the list. Then take a look at the information that appears on the right side.
In the “Request” tab (or “Payload” in Chrome), the “action” parameter of this request should be Articles\Processors\Article\GetList. What’s the value in the “Response” tab? If it’s empty, go to the server error log (That’s not the MODX error log!) and check the error message (that should get logged when the request fails with a 500 error).

Are you talking about this?

Is there any error here?
If so, how to check that?

Note: I am also having the same error on the “Article Container page” for my other website that was set up 2 days ago.

What is the status code for that request (Column “Status” in the list)? 500? 404?

The location of the server error log depends on the server settings (it won’t be in public_html!) and varies between different hosting providers.
I’m not familiar with ‘Hetzner’ and the console they provide. Maybe you could ask the provider for help.

is this?

It says “500 Internal Server Error” in red in the right upper corner.

Maybe take a look at this page of your provider about PHP-Konfiguration.

There is a section “PHP-Errorlog einrichten” at the bottom.
Or you could use the “display_errors” option to display the error message directly in the browser (during development).

after turning on display_error

I think this is a bug.

To fix it, open the file core/components/articles/src/Processors/Article/GetList.php and change the string 'charset' to 'modx_charset' in this line:

Hence, this plugin contains a bug/error, I don’t want to use this.
I tried to follow the Modx article docs

But I couldn’t be able to make this code [[!getResourcesTag?]] works.
Bob’s docs described the Archive and Categories. I don’t know how to implement that.
Hence, I don’t need the archive and categories I used only this code.

    <nav class="paging pt-16 mt-5" role="Blog">
    <ul class="pagination">

Now, on this site, there is no error. But still, the contact form is not working I don’t know why.
Can you suggest me anything?

<form action="[[~[[*id]]]]" method="post" class="contact-form">
    <div class="grid grid-cols-1 md:grid-cols-2 gap-7">
        <div class="">
            <input type="text" name="fname" placeholder="NAME" value="[[!+fi.fname]]">
            <p class="error">[[!fi.error.fname]]</p>
        <div class="">
            <input type="text" name="lname" placeholder="SURNAME" value="[[!+fi.lname]]">
            <p class="error">[[!fi.error.lname]]</p>
        <div class="">
            <input type="email" name="email" placeholder="E-MAIL ADRESS" value="[[!]]" required>
             <p class="error">[[!]]</p>  
        <div class="">
            <input type="text" name="phone" placeholder="TTELEPHONE" value="[[!]]">
             <p class="error">[[!]]</p> 
        <div class="col-span-full">
            <textarea name="text" id="" cols="30" rows="10" placeholder="MESSAGE" value="[[!+fi.text]]"></textarea>
            <p class="error">[[!+fi.error.text]]</p>
    <div class="flex flex-col md:flex-row pt-6 justify-between gap-x-10 gap-y-5">
        <label class="checkbox-input flex gap-3 items-start flex-1">
            <input type="checkbox" name="agree[]"
                class="h-4 w-4 checked:bg-primary border-2 border-gray-300 cursor-pointer mt-1.5"
                value="1" [[!+fi.agree:FormItIsChecked=`1`]] required>
            <span class="text-sm text-gray-300 leading-6">
                [[pdoField? &id=`[[++common_resource_id]]` &field=`contact_checkbox_text`]]
        <div class="pt-3 md:pt-0">
            <button type="submit" class="btn btn-primary inline-flex gap-2 items-center  pl-20">
                <svg  width="21" height="12" viewBox="0 0 21 12" fill="none" xmlns="">
                    <path d="M14.7186 0.703796L13.9088 1.51359L18.0135 5.93664H0.511658V7.15133H18.1485L13.9088 11.1865L14.7186 11.9963L20.4429 6.4765L14.7186 0.703796Z" fill="#D6BF92"/>