GoogleSitemap not updating unless I delete a page

Summary

All pages keep showing on sitemap.xml even if I uncheck the “Include this page in the sitemap?” option in the search engine tab.

Step to reproduce

Download GoogleSitemap and try to remove any page from the sitemap.

Observed behavior

Despite unchecking “Include this page in the sitemap?”, the page still shows in the sitemap:

The only way to get it off the sitemap is by deleting the page.
Also, changing the sitemap priority or sitemap update frequency doesn’t work either.

Expected behavior

I would expect the page to disappear from the sitemap after I uncheck that option.

Environment

MODX version tagged when creating the issue, Apache or NGINX with version, MySQL version, browser, etc. Any relevant information.

I don’t think this checkbox (“Include this page in the sitemap?”) is from the extra GoogleSiteMap.

It’s probably from the extra SEO Suite.
So maybe you just have to create your sitemap differently ([[!SeoSuiteSitemap]]).

1 Like

Damn, you are right, the tab was from SEO Suite.

But, for some reason it’s not displaying correctly as XML, it displays as plain text:

Did you follow the instructions here (section “SeoSuiteSitemap”)?

Especially the part

You have to manually create a resource within MODX, Template: (empty). go to the tab Settings and set Content Type: XML, Cachable and Rich Text should be ticked off.

Yep, I read the docs already. The settings were already set to that.

Interestingly, if I do:

[[!SeoSuiteSitemap? &type=`index`]]

it renders correctly.

EDIT: By correctly I mean the format is correct, if i do &type=index the sitemap is empty, which is definitely not what I want.