Google analitics blocks big brother integration

I updated big brother. The results is that it no longer has access to Google Analytics.
When I followed the instructions to authorize the Big Brother integration, google said

This app is blocked

This app tried to access sensitive info in your Google Account. To keep your account safe, Google blocked this access.

How to solver this?

Mate try to check into the analytics account. I stopped using big brother long time ago but I remember there is an area inside the analytics where you can modify the permissions for other apps that are connected to your analytics account.

Have you added custom oauth credentials in the past? Because there are no issues with the standard credentials provided with Big Brother that I know off, and the standard integration has been approved and everything.

Try removing (yes, removing) the bigbrother.native_app_client_id and bigbrother.native_app_client_secret system settings and running a reinstall for Big Brother. That should re-create the settings with their default values and let you re-authorize.

If you do want to use custom oauth credentials note that for v2 you’ll also need to enable the Google Analytics Admin API on the project and after 100 users your project needs to get approved by google.

Thanks for your help.
I ended with removing all the extras that had to do with google analytics plus the system settings and reinstalled everything. Google then let me authorize it.
The only thing now is that there is no data to be seen, neither in google analytics, but that is probably something to be sorted in google analytics, because I just moved to analytics 4.

Glad that sorted it.

Yeah, if you’ve just created the GA4 profile you’ll need to give it a few days before the widgets will start showing something interesting. And in 4 weeks it’ll start showing comparisons :slight_smile:

Still no Google Analytics data in Modx in spite of it saying that Big Brother is authorized.
I also have the script from Google in the head, so I can log into Google and see the analytics and that is working.
I also call in the head [[!Analytics? &webPropertyID=XXX]] as always was there.
The error log says:
[2021-11-01 08:38:25] (ERROR @ /XXX/public_html/core/xpdo/xpdo.class.php : 644) Could not load class: Analytics from analytics.
[2021-11-01 08:38:25] (ERROR @ /XXX/public_html/core/xpdo/xpdo.class.php : 1248) Problem getting service analytics, instance of class Analytics, from path /XXX/public_html/core/components/analytics/model/analytics/
How to solve this?
Thanks in advance for your help.

Here is another error appearing:
[2021-11-10 11:00:30] (ERROR @ /XXX/public_html/core/components/bigbrother/src/KeyMetrics.php : 52) PHP warning: Invalid argument supplied for foreach()

Have you updated big brother to 2.2.0? That warning was fixed and can, along with some other issues fixed in that release, prevent any data from showing.

Yes, big brother 2.2.0

Huh, interesting. On a closer look the error that was fixed was on line 59 not 52. The API is apparently not returning any data whatsoever?

If you can email a login to (please include a link to this topic) I wouldn’t mind taking a look at what’s going on there.

Login into our Modx site?