German Umlauts issue using seoSuite on fresh MODX setup

I have a fresh installation of MODX. After installing Sterc seoSuite, both the Google as well as the Yandex search result previews and, in addition, also the page title are displaying unexpected characters. In phpMyAdmin, all special characters are correct.

Is there any suggestion how to resolve this?

My Setup:

MODX 2.8.1-pl
MySQL 5.7, collation is utf8mb4_general_ci

confi.inc.php:

$database_type = ‘mysql’;
$database_server = ‘rdbms.strato.de’;
$database_user = ‘xxxxxxx’;
$database_password = ‘xxxxxxx’;
$database_connection_charset = ‘utf8’;
$dbase = ‘xxxxxxx’;
$table_prefix = ‘modx_’;
$database_dsn = ‘mysql:host=rdbms.strato.de;dbname=xxxxxxx;charset=utf8’;

Try this instead:

$database_connection_charset = 'utf8mb4';

Thank you Bob, I’ve set
$database_connection_charset = ‘utf8mb4’;
but with no luck.
Maybe this is an issue related to the vhost (provider is Strato).
It is interesting to see that the same MODX setup works perfect on my local host and also on different remote hosts of other providers.

Make sure the tables belonging to seosuite are also in a utf8mb collation. More often than not, the connection configuration for MODX does not apply to tables created later and the individual tables and columns may be set to something else.

Having said that… aren’t umlauts in the latin charsets as well? I’d expect those characters to work.

Out of curiosity, does the preview look better if you put the special characters at the start of the title? I’m wondering if the ellipsis there might be added in the middle of a character causing the render issue. If so that may then be a seosuite bug.

Also, check the text fields within the tables.

I started over with a fresh install. Collation is utf8_general_ci and the DB config is set to utf8mb4. Without the extra installed, it’s all fine – Umlauts display perfect and are stored in the database as they should be.

However, the seoSuite package still shows the same strange Umaut behavior. Because I did not have this issue on any other host, I tend to think this behaviour is specific to the constellation of the seoSuite script along with the host settings.
@markh: you are probably right assuming it’s a seoSuite bug.

In order to retrieve correct Umlauts in the title tag, this workaround does the job:

/* Output filter */
$charset = 'utf-8';
return htmlentities($input, ENT_COMPAT, $charset);

For the Google and the Yandex preview, I could not locate the script that prints the data to the screen so far.

The preview title is written here:

When you change the META title on the left side, the program makes an AJAX call to the processor mgr/resource/preview to generate the preview.

When you open the network tab in the developer tools of your browser and change the title, does the content of the parameter fields of the AJAX-request still look ok? Is the response from this request already mangled?

@halftrainedharry
Thank you for your hint.
I cannot get it working and so I decided to give up. It is too time consuming.
What I still do not understand is the fact that the seoSuite works pretty well on all my other servers. Nevertheless, I’ll go without suiteSeo on this server now.