FURLs not working


I’ve a fresh installation of Modx 2.7.2-pl on an Apache Server. But besides the main page (id=1) all other linked documents won’t show up when enabling FURLs, while they do when it’s not enabled.

Step to reproduce

For testing purposes the installations was made in an subdirectory called /mod.
I strictly followed the instructions given on https://docs.modx.com/revolution/2.x/administering-your-site/using-friendly-urls

Renamed ht.access to .htaccess
Set the MODX System Settings “Use Friendly URLs” to “YES”
Wrote the “” into the template.
Cleared the cache.
All documents which I tried are “published”

Observed behavior

When entering an FURL of another than the home page, I get a blank screen, while the shown URL is correct, like “https://www.marktapotheke.eu/mod/home2/

Expected behavior

…it should show the document “home2”


MODX 2.7.2-pl, MySQL 5

Kind regards,

1 Like

Because you’re in a subdirectory, you’ll need to change the RewriteBase line in the default ht.access file to match that:

RewriteEngine On
RewriteBase /mod/
1 Like

ooops! That easy… thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.