MODX Community

FURLs Ignoring Parent Resource

Hi,

I have FURLs turned on, but am running into an issue.

-The child resource is also a container with nothing after it (only way I can get the .html to be left off and work)

-Instead of the following which I want:
mysite dot com/parent/child (gives a 404)

-I am getting;
mysite dot com/child

This is not my main site on my server. It’s the second domain I’ve registered and am now using.

Revo 2.7.3

Rewrite www.example.com -> example.com – used with SEO Strict URLs plugin

RewriteCond %{HTTP_HOST} .
RewriteCond %{HTTP_HOST} ^www.(.)$ [NC]
RewriteRule ^(.
)$ https://%1/$1 [R=301,L]

The Friendly URLs part

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Do you have the use_alias_path System Setting turned on?

Thanks Bob. Yes, all the standard ones are turned on.

Automatically generate alias automatic_alias Yes
FURL Lowercase Aliases friendly_alias_lowercase_only Yes
FURL Alias Maximum Length friendly_alias_max_length 0
FURL Alias Real-Time friendly_alias_realtime No
FURL Alias Character Restriction Method friendly_alias_restrict_chars pattern
FURL Alias Character Restriction Pattern friendly_alias_restrict_chars_pattern /[\0\x0B\t\n\r\f\a&=+%#<>"~:`@?{}|^’\]/
FURL Alias Strip Element Tags friendly_alias_strip_element_tags Yes
FURL Alias Transliteration friendly_alias_translit none
FURL Alias Transliteration Service Class friendly_alias_translit_class translit.modTransliterate
FURL Alias Transliteration Service Class Path friendly_alias_translit_class_path {core_path}components/
FURL Alias Trim Characters friendly_alias_trim_chars /.-_
FURL Alias Word Delimiter friendly_alias_word_delimiter -
FURL Alias Word Delimiters friendly_alias_word_delimiters -_
Use Friendly Alias Path use_alias_path Yes 2020-05-17, 9:04 am

Area: Gateway (1 Setting)

Is the checkbox ‘Use current alias in alias path’ in the parent resource checked?
Maybe it is the same problem as in this thread https://community.modx.com/t/friendly-urls-issue-with-url/1694

1 Like

Winner! Thank you Harry.

It was not checked of. Appreciate you and Bob.

Just to address this point in your question: if you want the .html to be left off and not have to define “leaf” pages as containers, just suppress the file extension for the HTML content type in “Content” > “Content types” in the manager:

Further than this, you may want to consider turning friendly_alias_realtime to yes, so that users can immediately see the alias which is going to be generated and manually adjust it if needed ?
image

1 Like

Thanks! That did it too.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.