Fred toolbars and TinyMCE configurations

The It Fits theme is ready to package except for two things.

  1. The Fred element toolbars are sometimes vertical and sometimes horizontal. How can I make sure that they are always vertical?

  2. Is there any way to make a custom TinyMCE configuration be the default, or does it need to be specified in every container in every element where I want to use it?

According to fredRTETinyMCE.class.php, it should be possible, but there is no clue anywhere as to how to do it.

 * Get a local configuration option or a namespaced system setting by key.
 * @param string $key The option key to search for.
 * @param array $options An array of options that override local options.
 * @param mixed $default The default value returned if the option is not found locally or as a
 * namespaced system setting; by default this value is null.
 * @return mixed The option value or the default value specified.

And I have not been able to find Fred’s default TinyMCE configuration anywhere I’ve looked.

I believe the default configuration is defined here

In the final package everything is then combined and minified into assets/components/fredrtetinymce/web/fredrtetinymce.min.js

Thank you. I thought I was losing it, it had to be somewhere!

The default config is shown in the Fred docs, but there appear to be limits to a custom configuration, so I was hoping to find something that could be more fully customised.

selector: 'textarea',
plugins: 'codesample',
codesample_languages: [
{ text: 'HTML/XML', value: 'markup' },
{ text: 'JavaScript', value: 'javascript' },
{ text: 'CSS', value: 'css' },
{ text: 'PHP', value: 'php' },
{ text: 'Ruby', value: 'ruby' },
{ text: 'Python', value: 'python' },
{ text: 'Java', value: 'java' },
{ text: 'C', value: 'c' },
{ text: 'C#', value: 'csharp' },
{ text: 'C++', value: 'cpp' }
toolbar: 'codesample'

There is also this line in the documentation about RTE Configs: “If you create a config with a same name as your RTE, for example TinyMCE, this config will be used as a default one, overriding its defaults.”

Nice! Thank you. Must read docs more!