MODX Community

Formit - contact form - Mails are not delivered to Gmail

Hi
I use formit on my website flyfisherman.ch. The contact form works with the mail client spark, no problems at all. Lately i changed my mail account markus@flyfisherman to Gsuite and now the mails from the contact form do not come into Gmail, but still in Spark it works…
Any suggestions?
Thanks
Markus

1 Like

When you change your email, you have to change it in Modx too. There are system settings that will need to be changed…did you change any of them?

AFAIK gmail uses SMTP as a protocol for sending, those settings need to be entered. Here is a link to setting up your new email, and then an older forum post that might work a treat for you.

https://forums.modx.com/thread/78280/smtp-settings-for-gmail

So the emails are being received by your Spark email client but not showing in Gmail client since you switched? Check your email rules in your GSuite account. Sometimes they can be quite restrictive. Double-check your spam folder or try changing the email address on the formit call so they are sent to website@flyfisherman.com instead, see if they are being received in that mailbox. Also, check the error logs, sometimes phpmailer issues.

On another note…
What email address do you have assigned to [[formit? &emailFrom =``]] , if blank what email are you using for the system setting [[++emailsender]]? I highly recommend that either emailFrom or emailsender are filled in with a real email address that’s allowed to send from flyfisherman.com. i.e. markus@flyfisherman. This will reduce the likelihood of any SPF/ DMARC violations.

1 Like

Hi nuan88
I tried the smtp-settings for gmail but then i received a mail from Google that someone tried to login and that this application has been banned.
How to tell google that this application is my website contact form?
Thanks
Markus

1 Like

My goodness I don’t know what could be going on there, what application has been banned? If your SMTP settings were wrong I believe the only result would be the emails wouldn’tbe sent, which I think is what you have now.

Here is a new support article on getting gmail to work with Modx

Pls give us more info as you go on, we can help.

Try creating an App Password via Account > Security (https://myaccount.google.com/security) instead of using the regular account password; that might help satisfy Google’s requirements and allow you to send emails with it.

1 Like